please update Phishing Protection page with Malware info

VERIFIED FIXED in 3.0

Status

www.mozilla.org
General
VERIFIED FIXED
10 years ago
5 years ago

People

(Reporter: John Slater, Assigned: sgarrity)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 319589 [details]
Phishing and Malware Protection copy

Hi Steven. Our UX team has written some new copy for the Phishing Protection page that includes info about Malware Protection (for FF3 users). Can you make the necessary updates? Formatting, etc is the same, and the new copy is attached.

One catch: this new version of the page should only be shown to FF3 users. FF2 users should see the phishing-only version we currently have. (Johnathan, please clarify if I've missed something here)

Thanks,
John
(In reply to comment #0)
> One catch: this new version of the page should only be shown to FF3 users. FF2
> users should see the phishing-only version we currently have. (Johnathan,
> please clarify if I've missed something here)

More specifically, the old text should only be shown if we know they're are using FF2.  FF3 users *and any other users of other browsers/versions/etc* should all see the new content.
(Assignee)

Comment 2

10 years ago
Rather than having JavaScript output the entire contents of the page, I wonder if it wouldn't make more sense to have Javascript redirect FF2 users to another page (that would be a copy of the old one)? Maybe at something like /en-US/firefox/phishing-protection/firefox2/ ?

Thoughts?
(In reply to comment #2)
> Rather than having JavaScript output the entire contents of the page, I wonder
> if it wouldn't make more sense to have Javascript redirect FF2 users to another
> page (that would be a copy of the old one)? Maybe at something like
> /en-US/firefox/phishing-protection/firefox2/ ?
> 
> Thoughts?

Yeah, that would probably work - the key focuses are:

1) Not confusing existing FF2 users by telling them about features that don't exist for them
2) Making sure everyone else gets the most up-to-date, FF3 information

FWIW, I wasn't thinking that JS would have to generate the content or anything, just basically:

if (ff2) {
  // Remove the <div> with id="default-content" 
} else {
  // Remove the <div> with id="ff2-content"
}

But yeah, I'm not trying to tell you how to build web pages. :)  As long as #1 and #2 behave as described, I'm easy.
Blocks: 421348
Blocks: 432253
(Assignee)

Comment 4

10 years ago
Ok, I've got both pages setup now. The update version for everyone but Firefox 2 lives at the current URL (/en-US/firefox/phishing-protection/).

Visitors with Firefox 2 will be redirected to the old version at /en-US/firefox/phishing-protection/firefox2/

As the version detection and redirection is done with javascript, a message is displayed if Javascript is disabled:

 "If you are using Firefox 2, please see _Phishing Protection for Firefox 2_."

Does that work for everyone?
(Reporter)

Comment 5

10 years ago
That works great for me, thanks Steven. Johnathan?
2 Teensy fixes, and 1 Question.

Fix 1:  There's a missing letter at the start of question 3.

> "hishing and Malware Protection works by checking..."

should be

> "Phishing and Malware Protection works by checking..."


Fix 2: The Mac OS X options path in the last question is wrong.  This is probably my fault.

> On Mac OS X, go to Firefox > Preferences > Options ... > Security.

should drop the "> Options" bit, and read:

> On Mac OS X, go to Firefox > Preferences... > Security. 


Question:  I notice that the javascript magic beltzner suggested to only show the meaningful preferences path in the last question (Tools->Options...->Security vs. Firefox->Preferences...->Security) wasn't included.  Is that because the original suggestion was missed, or because doing it is pain?
(Assignee)

Comment 7

10 years ago
Fixes #1 and #2 are fixed in r12923.

In response to your question about using Javascript to show platform specific preference paths, I didn't know if this request. That said, it's no problem to do. I didn't go ahead and do it as it may warrant some re-wording:

"Phishing and Malware Protection options can be found on the Security Preferences pane. On Windows and Linux, go to Tools > Options ... > Security. On Mac OS X, go to Firefox > Preferences ... > Security."

For Windows/Linux, we'd have:

"Phishing and Malware Protection options can be found on the Security Preferences pane. Go to Tools > Options ... > Security."

On Mac OS X we'd have:

"Phishing and Malware Protection options can be found on the Security Preferences pane. Go to Firefox > Preferences ... > Security."

Wording change suggestions, or is that fine?
Works for me!
(Assignee)

Comment 9

10 years ago
This javascript fanciness is now in place (r12931)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 423911

Updated

10 years ago
Blocks: 422980
Verified FIXED; just double-checked the platform-specific Preferences/Options instructions across Mac, Windows, and Linux.
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.