RentACoder urls become malformed

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Andrew Sachen, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-09-15], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050606 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050606 Minefield/3.0pre

Upon attempting to log in to RentACoder, the browser gets redirected to http://www.rentacoder.com/RentACoder/authentication/Wc.asp?lngWId=1&lngIdentId=14769893 where the & should be just &. The same behavior can be experienced throughout the site (when posting comments for example), where the problem is simply that an entity is placed in the URL.
The issue cropped up some time in either 3 Beta 4 or Beta 5, and only effects Firefox 3.

Reproducible: Always

Steps to Reproduce:
1. Visit RentACoder
2. Attempt to log in with valid information.
Actual Results:  
After attempting to log in, the browser will be redirected to a malformed URL, which causes the page to display Warning: Invalid input paramater. Manually changing the URL will usually continue as normal.

Expected Results:  
The entity of the ampersand in the URL should be converted to an ampersand.

I'm in contact with a web developer from Exhedra Solutions (RentACoder's owner company), and he was aware of such a problem in Mobile versions of Internet Explorer as well. As the issue does not exist in older versions of Firefox or other web browsers, I don't believe it to be a "broken web site".

Comment 1

10 years ago
Is there any way you can verify for sure if this is a FF3 Beta 4 vs FF3 Beta 5 problem?

Thanks

I can't recreate with beta 5.
(Reporter)

Comment 2

10 years ago
I can't find a download for beta 4 to test with... But the problem still exists on the latest nightlies...

Comment 3

10 years ago
you can get beta 4 here:

ftp://ftp.mozilla.org/pub/firefox/releases/3.0b4

I'm not sure what I can't recreate the problem. I see that redirect page, but then it redirects me to right page...
(Reporter)

Comment 4

10 years ago
Huh... I guess not. Maybe it was a prerelease or nightly of a beta. It definitely has the problem in the latest nightlies, though.

Comment 5

10 years ago
I can confirm this happens for me, as of today, after applying the nightly auto-update earlier this morning. It does not happen with IE7 (using the IE Tab plugin).
(Reporter)

Comment 6

10 years ago
I've created a temporary fix for this problem: an extension I've named <a href="http://realityripple.com/software/xpi/ne/">No Escape</a>. I hope this gets fixed before 3.0!

Comment 7

10 years ago
Following up, I can confirm this still happens in the 3.1a1pre nightly 2008062804.
Reporter, are you still seeing this issue with Firefox 3.6.x or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2010-09-15]
Version: unspecified → 3.0 Branch
(Reporter)

Comment 9

8 years ago
Sorry, the site has changed since then and I don't have a way to reproduce the error anymore. So far as I know, though, this little bug went away in 3.5 or so.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.