[Tark Extension] JavaScript error: redeclaration of const ORGANIZER_ROOT_BOOKMARKS

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
9 years ago

People

(Reporter: cbook, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008050221 Firefox/3.0pre

Steps to reproduce:
-> Install the Tark Extension https://addons.mozilla.org/en-US/firefox/addon/2886
-> Open the Tark Preference Window
--> JS Error in Debug Build output/Error Console (see also Bug 432459)

JavaScript error: chrome://browser/content/places/controller.js, line 42: redeclaration of const ORGANIZER_ROOT_BOOKMARKS
similar to bug 406371, the extension probably included our source files (utils.js, controller.js) and that caused redeclaration.
Since that's not a Firefox bug i'm invalidating. Maybe would make sense to file a bug to give a common util file for extensions... but probably at this point Jetpack and FUEL can cover that.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.