bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Absolute positioned textarea over full screen or part of it: eg: left:0, right:0

RESOLVED DUPLICATE of bug 410146

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 410146
10 years ago
10 years ago

People

(Reporter: Klemen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

<textarea style="position:absolute;left:0;right:0;top:0:bottom:0;"></textarea> 

doesn't render properly. 

Reproducible: Always

Steps to Reproduce:
1. <textarea style="position:absolute;left:0;right:0;top:0:bottom:0;"></textarea>
Actual Results:  
Textarea stays as i haven't aplly positions.

Expected Results:  
Textarea should be resized allover browser.

Other tags with the same style works OK (<div>).

In FF2 the render result was better (strech only in horizontal but not vertical).

Comment 1

10 years ago
The new behavior is what the CSS 2.1 Spec calls for. A textarea is a replaced element.  A div is a non-replaced element.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 410146
You need to log in before you can comment on or make changes to this bug.