using Apple menu opens files three times

VERIFIED FIXED in M18

Status

P4
minor
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: bugzilla-e, Assigned: saari)

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; N; PPC; en-US; m16) Gecko/20000620
BuildID:    2000062008

When I open a file from the Apple menu in Mozilla, it opens three instances of
it. For most applications, it's not a problem, just the equivalent of launching
BBEdit (say) three times, nothing happens (except for some flickering). The same
goes for most documents.

Stationary, on the other hand, opens three instances.

Reproducible: Always
Steps to Reproduce:
1. Launch SimpleText. Type some sample text in the document.
2. Save As a stationary file, in Hard Disk:System Folder:Apple Menu Items
3. From Mozilla, select this file from the Apple menu.

Actual Results:  Three instances of the stationary file are opened in SimpleText
(as Untitled, Untitled 2, and Untitled 3).

Expected Results:  Only one instance of the file should be opened.

This may or may not be related to bug 36618.

This has happened to me for just about every build I can remember. May be a
problem specific to me, however.

I've seen it to open two instances rather than three, but I can't be more
specific about how to reproduce it.

Comment 1

19 years ago
Confirmed on 8.6/build 2000061411.  File must be in Apple Menu Items folder; it 
can not be a subfolder.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

19 years ago
I was able to reproduce this on OS9 62108 build

Comment 3

19 years ago
Eli, I know you've got your hands full but could you look at this and help me
find an owner.  It isn't major but I have no idea who would be able to debug
this issue.

Comment 4

19 years ago
umm...good catch!

I humbly suggest sfraser (who worked on the code)/jrgm (qa/menus).
Assignee: asa → sfraser
QA Contact: doronr → jrgm

Comment 5

19 years ago
worksforme 2000071108 mac os 9.0
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 6

19 years ago
jrgm@netscape.com, just in case the instructions were confusing.  DOn't open it
from Mozilla's File|Open.  Create that text file, add it to your Hard
Disk:System Folder:Apple Menu Items, then with mozilla open and active go to the
apple menu and select this text file.  I can repro with mozilla bits 071208 on OS 9 

Comment 7

19 years ago
Um, misunderstood the steps to reproduce (duh!). Yes, with a simpletext file
set as stationery, in the Apple Menu folder, selecting it from the Apple Menu
from Mozilla will launch two instances of the document in Simple Text. 
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

19 years ago
setting to m18
Target Milestone: --- → M18

Comment 9

19 years ago
Chris, this one's for you.
Assignee: sfraser → saari
Status: REOPENED → NEW
(Assignee)

Comment 10

19 years ago
nsbeta3
Status: NEW → ASSIGNED
Keywords: nsbeta3

Comment 11

19 years ago
nsbeta3+, but lower priority due to lower expected frequency.
Priority: P3 → P4
Whiteboard: [nsbeta3+]
(Assignee)

Comment 12

19 years ago
Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 13

19 years ago
Not seeing with 2000082308 OS9. Marking verified.

Comment 14

19 years ago
I thought I just verified this bug! And now I have to enter a comment! WHAT 
A RIPOFF :)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.