Last Comment Bug 43260 - Images are not displayed when "Content-encoding" HTTP header field is sent by web server
: Images are not displayed when "Content-encoding" HTTP header field is sent by...
Status: VERIFIED INVALID
:
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: Trunk
: x86 Windows 98
: P3 normal (vote)
: Future
Assigned To: Darin Fisher
: John Unruh
Mentors:
http://www.hmv.com/
: 50535 51337 56554 76582 (view as bug list)
Depends on:
Blocks: 61694
  Show dependency treegraph
 
Reported: 2000-06-20 20:38 PDT by Carey Evans
Modified: 2002-12-03 14:53 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Apache "asis" file with "Content-Encoding: x-foo" header (136 bytes, text/plain)
2000-09-27 15:26 PDT, Carey Evans
no flags Details

Description Carey Evans 2000-06-20 20:38:23 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m16) Gecko/20000619
BuildID:    2000061908

Images served by IBM HTTP Server for AS/400 and S/390 are not displayed.  This
appears to be because these servers add an invalid "Content-Encoding: binary"
header.  IE and NN4 still display the images in spite of this.

Reproducible: Always
Steps to Reproduce:
Visit a web page with images served by IBM HTTP Server for AS/400 or S/390, such
as http://www.as400.ibm.com/ or http://www.s390.ibm.com/.

Actual Results:  Images are replaced by their ALT text.

Expected Results:  Mozilla could ignore the bogus header and display the images
anyway.
Comment 1 rcummins 2000-06-25 20:05:31 PDT
I was able to duplicate this on Windows 95 build 2000062508.  As said, "Content-
Encoding: binary" in the HTTP response header breaks the image, test case at
http://www.burlco.lib.nj.us/moz/encoding/
Comment 2 Nick Rosier 2000-06-28 14:52:27 PDT
able to duplicate with build 2000062808 on win98
Comment 3 rcummins 2000-07-03 09:50:07 PDT
Able to duplicate with build 2000070220 under WinNT server 4.0 SP6a
Comment 4 rcummins 2000-07-03 14:01:39 PDT
Changed summary from "Images served by IBM HTTP Server for AS/400 and S/390 not
displayed"
Comment 5 rcummins 2000-08-24 19:57:26 PDT
Still not working using win32 2000082408 build.
Comment 6 Jesse Ruderman 2000-09-08 17:20:26 PDT
*** Bug 50535 has been marked as a duplicate of this bug. ***
Comment 7 Carey Evans 2000-09-27 15:23:50 PDT
This still exists, testing with Linux build 2000092621.

In addition, it doesn't just apply to images, it's just that images get the
Content-Encoding: binary header from IBM HTTP Server for AS/400.  Testing with
the Apache asis module, any file with any unknown encoding is affected.
Comment 8 Carey Evans 2000-09-27 15:26:05 PDT
Created attachment 15651 [details]
Apache "asis" file with "Content-Encoding: x-foo" header
Comment 9 Carey Evans 2000-10-03 14:44:24 PDT
It seems that IBM have decided to stop eating their own dogfood, and have moved
their AS/400^W iSeries website to AIX, so http://www.as400.ibm.com/ isn't a
useful example any more.  The site in bug #50535, http://www.hmv.com/, is still 
sending Content-Encoding: binary on images.
Comment 10 pnunn 2000-10-20 13:00:37 PDT
*** Bug 51337 has been marked as a duplicate of this bug. ***
Comment 11 Loco 2000-10-25 16:20:32 PDT
*** Bug 56554 has been marked as a duplicate of this bug. ***
Comment 12 Loco 2000-11-04 18:45:52 PST
From Aaron West (comment in bug #56554):

This issue can be resolved by adding the following lines to the http.conf file
on the S/390 & AS/400:

AddType .gif image/gif 8bit
AddType .jpg image/gif 8bit

and removing the line:
AddType .gif image/gif binary

This removes the encoding:binary out of the header and allows Mozilla to handle
images appropriately.

Thanks for your help everyone.

Cheers,

Aaron...
Comment 13 Carey Evans 2000-11-05 13:02:43 PST
Confirmed.  This lets Mozilla load images from our local web server.
Comment 14 tbthierrybernard 2000-11-06 17:17:00 PST
In the configuration change on the server, shouldn't the mime type for .jpg be 
image/jpeg as in:
AddType .jpg image/jpeg 8bit
Comment 15 Carey Evans 2000-11-07 12:48:29 PST
Yes, the MIME type should be image/jpeg there.  I didn't read the sample
configuration closely enough, and put the correct MIME type in anyway when
changing our web servers.
Comment 16 Darin Fisher 2000-11-30 13:15:48 PST
added keyword 4xp.
Comment 17 Gagan 2000-12-08 00:39:20 PST
http bugs to "Networking::HTTP"
Comment 18 Joe Lee 2001-01-03 14:13:17 PST
I don't know if this is a problem that really needs to be fixed in the browser
or not, but IBM has a PTF to fix this for the AS400 running V4R4 and V4R5. The
V4R4 PTF is SF64751, and the V4R5 PTF is SF64712.
Comment 19 Darin Fisher 2001-04-07 09:23:05 PDT
I agree, this is clearly a server misconfiguration bug.
Comment 20 rcummins 2001-04-17 09:11:41 PDT
Seems to have gotten fixed at some point anyway.  Weird that it got marked 
"invalid", as Mozilla was the only browser I could ever find that exhibited this 
behavior, despite it being "clearly a server misconfiguration bug".  "Be liberal 
in what you accept, and conservative in what you send."
Comment 21 Matthias Versen [:Matti] 2001-04-18 19:26:51 PDT
*** Bug 76582 has been marked as a duplicate of this bug. ***
Comment 22 John Unruh 2002-12-03 14:53:45 PST
Verified invalid.

Note You need to log in before you can comment on or make changes to this bug.