Porting XULRunner to Symbian OS

RESOLVED WONTFIX

Status

enhancement
RESOLVED WONTFIX
11 years ago
8 years ago

People

(Reporter: me, Unassigned)

Tracking

({meta, mobile})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 obsolete attachments)

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: 

This is the summary of porting XULRunner to Symbian OS, created for bugs dependency check convenience. When the XULRunner can be run on Symbian OS, this bug can be assigned to FIXED.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Reporter

Updated

11 years ago
Depends on: 432430
Reporter

Updated

11 years ago
Keywords: mobile

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: meta

Comment 1

11 years ago
I'm repeating myself in other Symbian related bugs but I do believe it is important to mention that Symbian has two mayor dialects: S60 (Nokia) and, often forgotten, UIQ (SonyEricsson, Motorola).
set platform to symbian
OS: Other → Symbian
Hardware: Other → All

Updated

10 years ago
Hardware: All → ARM

Updated

10 years ago
Depends on: 479584

Updated

10 years ago
Depends on: 479585

Updated

10 years ago
Depends on: 479587

Comment 3

10 years ago
Posted patch WIP to get XULRunner building (obsolete) — Splinter Review
WIP patch, that brings configure through the root directory and nsprpub. 

The change of an error to a warning when checking for the specification of temporary object desctruction order is due to the fact that the compiler treats conftest.c as a C file and hence barfs on the class declaration. Need to fix this.


Before applying this patch, you need to apply the patch in 442706 (https://bugzilla.mozilla.org/attachment.cgi?id=365330).

To run this, use the following command (GCCE can be replaced with WINSCW):
configure --target=arm-none-symbianelf --enable-symbian-target=GCCE --disable-debug --with-symbian-sdk=/c/Symbian/9.2/
S60_3rd_FP1 --enable-application=xulrunner --enable-default-toolkit=cairo-symbian --disable-javaxpcom
Christian, you should add SYMBIAN_SDK_DIR entry to config/autoconf.mk.in like MACOS_SDK_DIR if using AC_SUBST(SYMBIAN_SDK_DIR).  linker and compiler will need this path.

Comment 5

10 years ago
Posted patch Still WIP patch (obsolete) — Splinter Review
Updated WIP patch, that now runs through the whole configure process from the root.

It doesn't rely on the patch in bug 442706 anymore, but I will update the patch as soon as that code lands in mozilla-central. 

This command should get you all the way through configure:
configure --target=arm-none-symbianelf --enable-symbian-target=GCCE --disable-debug --with-symbian-sdk=/c/Symbian/9.2/S60_3rd_FP1 --enable-application=xulrunner --enable-default-toolkit=cairo-symbian --disable-javaxpcom --disable-jit
Attachment #366407 - Attachment is obsolete: true

Comment 6

10 years ago
Posted patch Fixed previous patch (obsolete) — Splinter Review
Fix to previous patch. Should actually work now, though still very hacky.
Attachment #366584 - Attachment is obsolete: true
Reporter

Comment 7

10 years ago
(In reply to comment #6)
> Created an attachment (id=366591) [details]
> Fixed previous patch
> 
> Fix to previous patch. Should actually work now, though still very hacky.

Great work! I could confirm this is working for me. A brand new Windows with MinGW/Mozilla-Build(MSYS inside)/S60 3rd FP1 SDK. Invoking configure script in root HG repository will do everything. Though, at this moment, I don't have other comment about this patch.

Comment 8

10 years ago
Removed the generated configure file plus removed an accidentally added local directory reference. Same procedure to get it running as previous.
Attachment #366591 - Attachment is obsolete: true

Updated

10 years ago
Depends on: 483590
Reporter

Updated

10 years ago
Depends on: 485141

Comment 9

10 years ago
Comment on attachment 366790 [details] [diff] [review]
Removed configure and a small fix

Made obsolete by bug 485141
Attachment #366790 - Attachment is obsolete: true
Depends on: 498324
Depends on: 498862
Depends on: 521186
No plans to complete the port
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.