If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

.jpg attachments automatically print and there's no preference setting to print only the text of a message

RESOLVED DUPLICATE of bug 387237

Status

Thunderbird
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 387237
10 years ago
8 years ago

People

(Reporter: Ted Shaneyfelt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-08-10)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Can't print message text without images

Neither the print page setup nor the preferences allow you to select any option to aviod this problem:

1. Receive a message (that you want to print) that contains attachments including JPG images (that you don't want to print, possibly very large).

2. Select to print the message

3. The images are printed with the message, with no option to omit them

(this is sometimes nice, but not always desirable, and though you can limit the number of pages to print, that's a poor way to work around part of the problem)

Please add a preference and a sticky option in the printing dialog to omit images when printing messages.

(BTW, not all types of attachments are printed, so the existing functionality is also a somewhat inconsistent) 



Reproducible: Always

Steps to Reproduce:
1. Receive a message (that you want to print) that contains attachments including JPG images (that you don't want to print, possibly very large).

2. Select to print the message

3. The images are printed with the message, with no option to omit them
Actual Results:  
pages of images at the end of the message

Expected Results:  
Some way to turn off image printing (other than preview and limiting page count)

Provide an option in preferences to omit images when printing. Also add the option to the print dialog, with an always-use-this-preference type checkbox, or perhaps always set the preferences accordingly.

Also tried (gasping at straws) turning off the display of emoticons as images, hoping it would have the desired side-effect, and that had no effect on image attachments either.

Comment 1

10 years ago
The only default way I see for now is to uncheck
view/display attachments inline

see print preview and no pic att now

For the real thing, see this extension that gives you all those options and more:
https://nic-nac-project.org/~kaosmos/printingtools-en.html
Reporter any reply to comment #1?
Whiteboard: closeme-2009-08-10

Updated

8 years ago
Whiteboard: closeme-2009-08-10 → closeme 2009-08-10
RESO INCO due to lack of response to last question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Comment 4

8 years ago
Hmm, still the comment #1 is more of a workaround. Anyway, it's actually a dupe

It is not obvious and the decision would normally be made in the moment of printing, after opening print preview or such. Switching view back and forth for this is kinda odd, not to say it may be left in the respective "not inline" state with further confusion. + We already have "print backgrounds or not" with the expectation implied.

I think this is an issue. More of an Ui thing. I think there was another print bug to work on various aspects, maybe including this.
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 387237
You need to log in before you can comment on or make changes to this bug.