padding is added to the width or height of DIV when expressed in percentage (CSS)

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Theo Abazis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

if, for example, we have a 100% width of a DIV, and padding 10px, this will activate the scrollbars because the width (or height) becomes 100% + 10px.
It renders correctly in IE7 :-(

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
Actually Firefox does it right and IE does it wrong.
complete width = margin-left + border-left-width + padding-left + width +
                 padding-right + border-right-width + margin-right
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.