mail.addr_book.displayName.lastnamefirst is a string but managed as a boolean

RESOLVED WONTFIX

Status

--
minor
RESOLVED WONTFIX
11 years ago
11 years ago

People

(Reporter: laurent.bauvens, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: version 3.0a1pre (2008050703)

The prefs key mail.addr_book.displayName.lastnamefirst accepts only true and false values. Logically, it should be a boolean key. 

Reproducible: Always

Steps to Reproduce:
1.Menu Tools > Options > Advanced > General tab > Config editor button
2.Type mail.addr_book.displayName.lastnamefirst,  
3.Double click on the key name
4.To change the value from false to true, you must type 't', 'r', 'u', 'e'.
Actual Results:  
Default value is 'false' but the key type is 'string'; the dialog displays a text box where you can type any string you want. But it seems that if the string value is different than 'true' or 'false', the default value is taken.

Expected Results:  
Key should be managed as a boolean key with a (0|1) value.

This behaviour is present in the last 2.0.0.14 and also in the 3.0a1
The mail.addr_book.displayName.lastnamefirst is treated as a string in preferences because it is capable of being set from a locale file (messenger.properties) for different locales to override the setting.

If we changed the preference to a boolean, then that would mean we could not have this locales override. Therefore I'm mark this as won't fix because it would loose us functionality we want to maintain.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.