Closed Bug 432656 Opened 13 years ago Closed 12 years ago

User Option to Install Add-On in Browser Root

Categories

(Toolkit :: Add-ons Manager, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: david, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9

For Firefox 3, the new Extension Manager should have a user option to install add-ons in the Firefox root directory instead of in the profile.  

If an extension has updates almost as frequently as the browser itself, it's quicker to install the extension in the root when there are multiple profiles, eahc of which would otherwise have to be updated.  In an business environment where anyone can walk up to any PC and logon to his or her own account and profile, installing extensions only in all profiles can be prohibitive.  

Reproducible: Always




See thread with subject "installing .xpi extensions globally vs. per-profile" in newsgroup <news://news.mozilla.org:119/mozilla.dev.extensions>.  See especially my question (6 May) and its responses.  

On my home PC, I have four profiles.  I use three, and the fourth is for "guests".  I have five extensions that I want for all four profiles.  Thus, when I can, I install the extensions in the root directory, not in the profiles.  Installing a new version of an extension once seems to outweigh any bother with having to re-install extensions when I upgrade the browser itself.  

Yes, I am using SeaMonkey, not Firefox.  However, SeaMonkey 2 will be using the same Extension Manager as Firefox 3.
I would like to see several of the following options: (not sure if this makes better sense)

(a) always install extensions in profile
(b) always install extensions in root directory
(c) default to (a) or (b), but allow extension to override (e.g. setting in .rdf file)
(d) pop up checkbox each time to let user decide 
Product: Firefox → Toolkit
Can anyone explain how this bug is marked "New" but also "Fixed"?  Bugzilla has no option that I can find to remove the "Fixed".
(In reply to comment #2)
> Can anyone explain how this bug is marked "New" but also "Fixed"?  Bugzilla has
> no option that I can find to remove the "Fixed".

You like have javascript disabled. Bugzilla doesn't handle such things well
Oops!  You're right (comment #3).
This is I think extension material, the core EM should always install to the profile install location.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WONTFIX
sigh. Well, is there a "wish list" site for extensions?

I suppose it doesn't matter to me anymore since lately I've given up trying to write firefox extensions.
You could try the forums at http://forums.mozillazine.org
It is my understanding that the Extensions Manager will not permit extensions to be installed in the browser root and that nothing internal to an extension can override this prohibition for the extension's own installation.  Thus, the justification for closing this RFE -- "extension material" -- is invalid.  Reopening.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(In reply to comment #8)
> It is my understanding that the Extensions Manager will not permit extensions
> to be installed in the browser root and that nothing internal to an extension
> can override this prohibition for the extension's own installation.  Thus, the
> justification for closing this RFE -- "extension material" -- is invalid. 
> Reopening.

Your understanding is not correct. The extension manager will load and use extensions installed in many places, the installation directory being one of them, where the default theme is in fact installed.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → WONTFIX
On 6 May 2008, in the mozilla.dev.extensions newsgroup, I asked:  
> Will the option still be available to install an extension in the
> SeaMonkey 2 root?  Or will all extensions have to be installed in the
> profile? 

On 7 May 2008, in the same newsgroup (in the same thread), Philip Chee replied: 
> SeaMonkey 2.0 uses exactly the same addons manager as Firefox 3.0, so
> install.js will NOT be supported. The new Addons manager does support a
> command line option to install globally but you can't trigger it from
> the extension itself. 

What this RFE bug requests is that the Add-Ons Manager support root installation of extensions when such installation is implemented as an option within an extension or when an extension permits only root installation.  Further, that support should be USER-ORIENTED, which is not satisfied by use of a command-line operation.  

Chee's response a year ago (which led to this bug report being submitted) is contrary to Townsend's comment #9.  The discrepancy between Chee's and Townsend's comments should be resolved before closing this bug report.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(In reply to comment #10)
> On 6 May 2008, in the mozilla.dev.extensions newsgroup, I asked:  
> > Will the option still be available to install an extension in the
> > SeaMonkey 2 root?  Or will all extensions have to be installed in the
> > profile? 
> 
> On 7 May 2008, in the same newsgroup (in the same thread), Philip Chee replied: 
> > SeaMonkey 2.0 uses exactly the same addons manager as Firefox 3.0, so
> > install.js will NOT be supported. The new Addons manager does support a
> > command line option to install globally but you can't trigger it from
> > the extension itself. 
> 
> What this RFE bug requests is that the Add-Ons Manager support root
> installation of extensions when such installation is implemented as an option
> within an extension or when an extension permits only root installation. 
> Further, that support should be USER-ORIENTED, which is not satisfied by use of
> a command-line operation.  
> 
> Chee's response a year ago (which led to this bug report being submitted) is
> contrary to Townsend's comment #9.  The discrepancy between Chee's and
> Townsend's comments should be resolved before closing this bug report.

It is not contrary in my opinion.

My statement is that if an add-on is already installed in the browser installation directory then the extension manager will detect and load it. This happens for the default theme for example and I believe that SeaMonkey 2 puts the DOM Inspector and Chatzilla there too.

This bug report, unless I have completely misunderstood it, is about giving the user the option to install add-ons into the browser installation directory instead of the profile when they install the extension through the browser. That is something that we won't be implementing in the core code.
> My statement is that if an add-on is already installed in the browser
> installation directory then the extension manager will detect and load it. 

This is a chicken vs egg paradox.  If an add-on is already installed in the browser root, a new version can then be installed over it.  But how do we get the first version of a new add-on installed in the root?  And how do we reinstall add-ons into the root after updating the browser (which erases root-installed add-ons)?  

I don't really understand the strong opposition against having add-ons installed in the browser root.  I have five extensions installed in the root for SeaMonkey 1.1.16: Adblock Plus, LiveHTTPHeaders, Mnenhy, PrefBar, and Show Passwords.   

The only extension installed in my profiles is FlashBlock because it does not have an option for root installation.  That profile installation is problematical when a new version of FlashBlock is released.  The old version must first be removed, with removal required for each of my four profiles rather than only once for the root.
(In reply to comment #12)
> > My statement is that if an add-on is already installed in the browser
> > installation directory then the extension manager will detect and load it. 
> 
> This is a chicken vs egg paradox.  If an add-on is already installed in the
> browser root, a new version can then be installed over it.

Actually no, but only because bug 300967 hasn't been resolved satisfactorily yet.

> But how do we get
> the first version of a new add-on installed in the root?  And how do we
> reinstall add-ons into the root after updating the browser (which erases
> root-installed add-ons)?

Simply by extracting the add-ons files into the install location (https://developer.mozilla.org/En/Installing_extensions). Of course if we aren't talking about add-ons that are shipping with the browser itself then likely you want to put them somewhere other than the installation directory anyway. There are global install locations on all platforms that won't be wiped by an application update.

> I don't really understand the strong opposition against having add-ons
> installed in the browser root.  I have five extensions installed in the root
> for SeaMonkey 1.1.16: Adblock Plus, LiveHTTPHeaders, Mnenhy, PrefBar, and Show
> Passwords.   

There is no opposition to having the ability to have add-ons in the installation directory (in fact it is very much a wanted feature to allow applications to ship with extensions). Nor is there opposition to having the other global install locations (so other applications and system administrators can install extensions to integrate with the browser easily). This bug is purely about providing the user UI and choice to do this, it is this that we're not going to include in the core code. That isn't to say that SeaMonkey couldn't implement this feature or that an extension could provide it, the support is there it is just the UI that we won't be adding.

> The only extension installed in my profiles is FlashBlock because it does not
> have an option for root installation.  That profile installation is
> problematical when a new version of FlashBlock is released.  The old version
> must first be removed, with removal required for each of my four profiles
> rather than only once for the root.

I'm not sure what you mean by removing the old version. You can just go to the add-ons manager, search for updates and install it in a couple of clicks. I'l grant you for multiple profiles it can be bothersome to do it many times, but that is not a case we're optimising for right now.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → WONTFIX

This bug blocks bug 300967.

You need to log in before you can comment on or make changes to this bug.