If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Running a second instance of mozilla.exe does not work

VERIFIED DUPLICATE of bug 50424

Status

Core Graveyard
Cmd-line Features
P3
normal
VERIFIED DUPLICATE of bug 50424
18 years ago
9 years ago

People

(Reporter: Koike Kazuhiko, Assigned: Scott MacGregor)

Tracking

Trunk
Future
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Browser can't be launched after launching mail by "-mail" option.

(1) On Command prompt, execute "mozilla -mail".
(2) Execute "mozilla". Nothing happens.

WinNT Build: 2000061808

Comment 1

18 years ago
This bug is happened following situation.
(1) on command prompt, enter 'mozilla.exe -mail'.
    It launch Mozilla Messenger window.

(2) while Messenger window is opened, enter 'mozilla.exe'.
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
(3) Moziila Browser is not launched.

(add oliver@1000cp.com to CC:)

Comment 2

18 years ago
This is invalid.  When you use -mail parameter, you're already launching 
"mozilla.exe".  To bring up the browser, you will need to choose the menu item 
from the Tasks menu in the mail window.  You can't run two instances of 
"mozilla.exe"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 3

18 years ago
.
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
Why invalid?

I want to use Mozilla same as Communicator4.x.

I created tow shortcut icon on my windows desktop.
One is "mozilla.exe" for launching a browser, and another one is
"mozilla.exe -mail" for launching a messenger.
While using messenger, "mozilla.exe" shortcut seems be disable.

In other case, when I iconize a messenger in a task bar,
do I need to open(normalize window) a messenger for using browser?

Do I need to open a messenger at a once, for use browser?

Comment 5

18 years ago
sorry, last one line was too much.
(Reporter)

Comment 6

18 years ago
Mozilla for Linux can be launched by executing "./mozilla" on
shell prompt after launching mailer. 
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

Comment 7

18 years ago
I don't think this is a mail problem. You'd probably get the same issue if try 
to start the browser and composer (w/ -composer parameter).  
(Reporter)

Updated

18 years ago
Component: Mail Back End → Browser-General
Product: MailNews → Browser

Comment 8

18 years ago
Perhaps the default action when launching mozilla.exe with no parameters should
be to open a new "Navigator" window, no matter what else is running.. This is
the behavior that IE5 exhibits, etc, etc..

Comment 9

17 years ago
This seems to be a Win32-only bug. I think the expected behavior is to open the
requested application specified on the cmd line, for example:
-mail would open the messenger, etc.
if no application is specified then it should default to new Navigator window.

Revising summary to more accurately reflect behavior. Updating component.
Confirmed on Win32 nightly 070608.
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps: Cmd-line Features
Ever confirmed: true
Summary: Browser can't be launched after launching mail by "-mail" → Running a second instance of mozilla.exe does not work
(Assignee)

Comment 10

17 years ago
I doubt we get to this in beta3. adding 4xp parity keyword. 
Keywords: 4xp
Target Milestone: --- → Future
Created attachment 18365 [details] [diff] [review]
An easy fix

Comment 12

17 years ago

*** This bug has been marked as a duplicate of 50424 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 13

17 years ago
vrfy dup
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: Cmd-line Features → Cmd-line Features
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.