Closed Bug 432702 Opened 12 years ago Closed 11 years ago

scrolling of a XUL document doesn't work

Categories

(Firefox for Android Graveyard :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
fennec1.0a1

People

(Reporter: dougt, Assigned: Gavin)

Details

Attachments

(1 file)

scrolling of a xul document doesn't work.  I only see a flash of the window.
does it work now?
Duplicate of this bug: 434079
Still doesn't work, because XUL documents don't scroll themselves (though elements within them can scroll). Not sure what to do here... I suppose we could look for scrollboxes and try to scroll those, or something.
Doesn't fix panning, but might as well land this for the moment to avoid exceptions being thrown just for loading a xul page.
Attachment #331164 - Flags: review?(mark.finkle)
Attachment #331164 - Flags: review?(mark.finkle) → review+
Comment on attachment 331164 [details] [diff] [review]
don't throw when loading xul docs (checked in)

http://hg.mozilla.org/mobile-browser/index.cgi/rev/cbd3f11f2c67
Attachment #331164 - Attachment description: don't throw when loading xul docs → don't throw when loading xul docs (checked in)
Flags: blocking-fennec1.0+
Target Milestone: --- → Fennec A1
Wonder whether bug 111034 helps here.
Assignee: nobody → gavin.sharp
So I think we can remove the patch that was checked in now that bug 111034 is fixed, since the documentElement's scrollHeight will be correct.

As far as I can tell, about:config is working correctly, except that the list of prefs doesn't have a scroll bar like it does in Firefox for some reason. If it did you could at least manually scroll (panning still wouldn't work because it's not the root document scrolling, but a child element).

We can probably do something like detecting whether you're starting a pan over a scrollable child elements, and scrolling them instead of the document, but that's a different issue than about:config's scrollbars not showing up, I think.
(In reply to comment #7)
> As far as I can tell, about:config is working correctly, except that the list
> of prefs doesn't have a scroll bar like it does in Firefox for some reason. If
> it did you could at least manually scroll (panning still wouldn't work because
> it's not the root document scrolling, but a child element).
> 

We kill scrollbars using a style override here:
http://hg.mozilla.org/mobile-browser/file/a48464d3ea42/chrome/content/browser.js#l84
Going to resolve this as fixed since XUL documents that actually have widths/heights larger than the viewport are scrollable. Going to file two followups about 1) panning/scrolling subframes (e.g. scrollable XUL elements, iframes). and 2) reverting the patch landed in this bug per comment 7.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Gavin, can you identify the follow up bugs mentioned in comment #9 as I'm not seeing scrollable functionality on about:config over builds:

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.3a1pre) Gecko/20090817 Fennec/1.0a3pre


Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20090817
Fennec/1.0b3pre
Flags: in-litmus?
Hmmm, I think the current iframe/frame scrolling code could work for XUL, just needs to be altered to look for the right DOM elements and to work outside of the tile container area.  It may need to be a copy of the code with alterations to keep the searching fast for both sides.
is this really resolved fixed?  I cannot scroll about:config?
Let's re-open this to get some traction on it (as well as it not being fixed).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Was fixed when this was landed :)

It's usually better to open a new bug, rather than reopen an old one, just to avoid confusing things.
Status: REOPENED → RESOLVED
Closed: 12 years ago11 years ago
Resolution: --- → FIXED
Ok by me, the new bug is 511133


verified FIXED on panning the about:config page (and not the element within it) over builds:

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.3a1pre) Gecko/20090818 Fennec/1.0a3pre


Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20090818
Fennec/1.0b3pre
Status: RESOLVED → VERIFIED
This is regression tested on litmus testcase: 

https://litmus.mozilla.org/show_test.cgi?id=9788
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.