If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

maxlength in text input is ignored

VERIFIED FIXED in M17

Status

()

Core
Layout: Form Controls
P1
critical
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Henrik Gemal, Assigned: Joe Francis)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
In fx http://gemal.dk/browserspy/x.html I have a maxlength on the Name input 
field.
In Netscape 4.73 you can only enter 10 chars but in Mozilla you can enter as 
many as you like. Mozilla is simply ignoring the maxlength property.

Build 2000062020

Updated

18 years ago
Assignee: rods → beppe
Summary: maxlength in text input is ignored → maxlength in text input is ignored

Comment 1

18 years ago
reassigning

Comment 2

18 years ago
assigning to Joe
Assignee: beppe → jfrancis
Target Milestone: --- → M17

Updated

18 years ago
Blocks: 43225

Comment 3

18 years ago
*** Bug 43333 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
Add keyword regression (and others) since this was originally filed as bug #7140
and that was resolved long ago.
Keywords: 4xp, nsbeta2, regression

Comment 5

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]

Comment 6

18 years ago
updated priority and severity
Severity: normal → critical
Priority: P3 → P1
(Assignee)

Comment 7

18 years ago
I'm assuming that ender-lite is not passing along the maxlength info to 
the editor, since we've had this working in the editor for a long time. 
CC'ing mike.
Status: NEW → ASSIGNED

Comment 8

18 years ago
Attaching a minimized HTML 4.01 Strict test case.

Comment 9

18 years ago
Created attachment 10697 [details]
Minimized test case
(Assignee)

Comment 10

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
Marking VERIFIED FIXED on:
- MacOS9 2000-07-06-08-M17 Commercial
- Linux6 2000-07-07-10-M17 Commercial
- Win98  2000-07-07-13-M17 Commercial
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.