Middle click bookmarks folder in Library replaced current tab.

VERIFIED FIXED in Firefox 3.5

Status

()

P3
normal
VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: alice0775, Assigned: alice0775)

Tracking

3.0 Branch
Firefox 3.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-us; rv:1.9pre) Gecko/2008050706 Minefield/3.0pre Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-us; rv:1.9pre) Gecko/2008050706 Minefield/3.0pre

Middle click bookmarks folder in Library replaced current tab.
But, middle click bookmarks folder in Sidebar, bookmarks toolbar and main menu does not replace current tab.

Should be same behavior.


Reproducible: Always

Steps to Reproduce:
1.Start Firefox with new profile
2.You confirm there are two tabs. (or Open two tabs)
3.Open Library
4.Select "Bookmarks Menu" > "Mozilla Firefox"
5.Middle click "Mozilla Firefox" folder
Actual Results:  
Current tab was replaced.

Expected Results:  
Shold not be replaced. just append tabs.

In the method of PlacesOrganizer.onTreeClick

I don't know well, but 
PlacesUIUtils.openContainerNodeInTabs(selectedNode); must be
PlacesUIUtils.openContainerNodeInTabs(selectedNode,aEvent); .

Updated

11 years ago
Assignee: nobody → alice0775
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

11 years ago
Created attachment 319989 [details] [diff] [review]
patch

thank you! i've done the patch for you, since you have found problem and solution i'm assigning to you to give correct credits :)
Attachment #319989 - Flags: review?(dietrich)

Updated

11 years ago
Whiteboard: [has patch][needs review dietrich]
Version: unspecified → 3.0 Branch
Priority: -- → P3
Target Milestone: --- → Firefox 3.1
Comment on attachment 319989 [details] [diff] [review]
patch

r=me, thanks!
Attachment #319989 - Flags: review?(dietrich) → review+

Updated

11 years ago
Whiteboard: [has patch][needs review dietrich] → [has patch][has review]

Comment 3

10 years ago
http://hg.mozilla.org/mozilla-central/rev/007c88ff0d12
Status: NEW → RESOLVED
Last Resolved: 10 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Whiteboard: [has patch][has review]

Comment 4

10 years ago
verified: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081112 Minefield/3.1b2pre
Status: RESOLVED → VERIFIED
Target Milestone: Firefox 3.1 → Firefox 3.5
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.