Firefox textarea don't wrap text

RESOLVED WONTFIX

Status

()

Core
Layout: Form Controls
--
enhancement
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: Igor, Unassigned)

Tracking

1.9.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix? see comment 1])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

When typing a long message in the textarea with fixed width, a horizontal scroll bar appears rather than a vertical.


Reproducible: Always

Steps to Reproduce:
type long word in text area
example: aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa


Expected Results:  
long text should wrap as in IE

Updated

10 years ago
Severity: minor → enhancement
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
For what I know IE behaviour is not W3C compliant.
To Tech Evangelism or INVALID?
Keywords: qawanted
Whiteboard: [wontfix?]
Whiteboard: [wontfix?] → [wontfix? see comment 1]

Comment 2

9 years ago
ggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggggg
CONFIRMED: This issue does occur on 3.0 for the latest release: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20, but it's gone on trunk as well as 1.9.1....


textbox wraps for me on the following builds:


Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090522 Minefield/3.6a1pre ID:20090522032716

and

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090522 Shiretoko/3.5pre ID:20090522030802


and back checked on Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: Trunk → 2.0 Branch
Is this a wontfix?
Keywords: qawanted
Component: General → Layout: Form Controls
Product: Firefox → Core
QA Contact: general → layout.form-controls
Version: 2.0 Branch → 1.9.0 Branch
Yeah, if this is broken on 1.9.0, unless it regressed recently, it's a WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
As a 1.9.0 bug this is indeed wontfix.

Of course the right resolution here is probably to mark this duplicate of the long-standing RFE we implemented in 1.9.1...
You need to log in before you can comment on or make changes to this bug.