Closed Bug 432794 Opened 16 years ago Closed 16 years ago

Allow loading chrome scripts in test cases

Categories

(Calendar :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: Fallen, Assigned: mschroeder)

Details

Attachments

(2 files)

We are currently duplicating some functions from calUtils in our unit tests. This can be avoided by loading calUtils.

This is one of the patches that emerged from my upcoming "all following" patch.
Attachment #319949 - Flags: review?(daniel.boelzle)
Comment on attachment 319949 [details] [diff] [review]
[checked in] Load calUtils in testcases - v1

r=dbo with one question resolved: Why don't we load calUtils.js from dist/bin/js?
Attachment #319949 - Flags: review?(daniel.boelzle) → review+
I thought it would be better to load from chrome, since we might want to load other scripts at some point. (i.e I load calendar-item-editing.js in the all-following testcase)
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
Re-opening. On trunk I get following error message caused by accessing a non-chrome URL while running the unit tests with 'make check': "uncaught exception: Trying to load a non-local URI." On trunk it _must_ be a chrome URL, see http://developer.mozilla.org/en/docs/mozIJSSubScriptLoader.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: philipp → mschroeder
Status: REOPENED → NEW
Tests can access chrome directly without using the jar.
Attachment #320590 - Flags: review?(philipp)
Attachment #319949 - Attachment description: Load calUtils in testcases - v1 → [checked in] Load calUtils in testcases - v1
Status: NEW → ASSIGNED
Comment on attachment 320590 [details] [diff] [review]
Fix non-chrome url issue

Wow, didn't know that works. Nice catch, r=philipp
Attachment #320590 - Flags: review?(philipp) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → FIXED
Checked on mxr.mozilla.com -> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: