Last Comment Bug 432798 - EULA browsing mode is crippled (no Back button, context menu, or statusbar) (license,licence,agreement)
: EULA browsing mode is crippled (no Back button, context menu, or statusbar) ...
Status: RESOLVED DUPLICATE of bug 446446
[MU+]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Linux
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 394046
  Show dependency treegraph
 
Reported: 2008-05-08 04:13 PDT by [:Aleksej]
Modified: 2009-02-09 13:32 PST (History)
7 users (show)
mconnor: blocking‑firefox3-
mconnor: wanted1.9.0.x+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description [:Aleksej] 2008-05-08 04:13:26 PDT
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008050707 Minefield/3.0pre

Steps to reproduce:
1. Create a new profile.
2. Load Firefox with the profile.
3. See the EULA, read it until the MPL or Privacy Policy link.
4. Click the link to read the MPL or PP.
5. Try to read the rest of EULA.
6. Try from the beginning, but do not click any link, just try to look at the URL or copy it.

Actual results:
5. No way to go back: pressing Alt-Left or Backspace does nothing, and there is no Back button.
6. There is neither status bar nor context menu. I can only copy the visible text.

Expected results:
5. Existing ways to go back to the EULA — a back button and Alt-Left / Backspace.
6. A way to see and copy a URL of a link.
Comment 1 Mike Connor [:mconnor] 2008-05-08 08:09:15 PDT
Kinda sucks, but not going to block at this point.
Comment 2 Samuel Sidler (old account; do not CC) 2008-07-21 18:19:32 PDT
Who could own this if we want it before major update?
Comment 3 Mike Beltzner [:beltzner, not reading bugmail] 2008-07-30 14:20:11 PDT
Would fixing bug 446446 also fix this? I believe that it would.
Comment 4 Mike Beltzner [:beltzner, not reading bugmail] 2008-07-30 14:38:21 PDT

*** This bug has been marked as a duplicate of bug 446446 ***
Comment 5 Mike Beltzner [:beltzner, not reading bugmail] 2008-07-30 14:52:32 PDT
Bug 446446 has been fixed now, so this should be FIXED. Reporter, can you verify?
Comment 6 [:Aleksej] 2008-07-31 11:44:17 PDT
The problem is still present in:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.2pre) Gecko/2008073104 GranParadiso/3.0.2pre
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a2pre) Gecko/2008073102 Minefield/3.1a2pre

Comment 7 juan becerra [:juanb] 2008-08-14 17:29:07 PDT
The problem is still present in 3.0.2pre, on Linux as reported.

Note You need to log in before you can comment on or make changes to this bug.