Password Manager cannot remember three fields for login

RESOLVED DUPLICATE of bug 222589

Status

()

RESOLVED DUPLICATE of bug 222589
10 years ago
10 years ago

People

(Reporter: mozilla-bugs-2011.08, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5

Some banks now require three fields (User Code, ID Number, Password) to be filled in, not just two. The Firefox Password Manager remembers the password on these forms, but not the User Code or ID Number.


Reproducible: Always

Steps to Reproduce:
1. Enter login information at banking website with three fields.
2. Instruct Password Manager to save the password
3. Return to login form

Actual Results:  
Only the password field is filled in, the User Code and ID Number fields are blank.

Expected Results:  
I expected all three fields to be filled in.

Comment 1

10 years ago
Really, password manager should have all the capabilities of form filler, capable of remembering any number of fields of any name, by name, that happen to have a password field included in the form -- such memories should be applicable only to pages of the site that request at least those same fields by those same names.  (The order of the fields could be canonicalized (sorted?) in the saved version, to make it quick to find an appropriate memory.  If there are multiple qualifying memories, the URL and/or the User should be consulted to help make the choice)

A special case might seem appropriate for 2-field password forms, that they might be applicable to any page that requests exactly 2-fields, one of which is a password, even when the names don't match.  That seems to be the limited case that Password Manager is presently attempting to address, but that is a subset of the interesting cases.

For extra credit, when the Password Manager requests permission to save the password, would be that the dialog would contain a list checkboxes named with the names of the fields in the form, by name, all preselected.  The user could choose to uncheck specific fields, to not be saved with the entry, which could broaden the applicability of the saved data to smaller forms, and which would eliminate data that is likely to be responded to differently in future uses of the form.
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> For extra credit, when the Password Manager requests permission to save the
> password, would be that the dialog would contain a list checkboxes named with
> the names of the fields in the form, by name, all preselected.  The user could
> choose to uncheck specific fields, to not be saved with the entry, which could
> broaden the applicability of the saved data to smaller forms, and which would
> eliminate data that is likely to be responded to differently in future uses of
> the form.
> 

This is a great idea. A small 'options' button on the Password Manager toolbar that when pressed would present a dialog box which lists all the non-hidden input tags. I'm sure that in the future other options will be added, such as "this domain/subdomain/page only".

Comment 3

10 years ago
Thanks for liking my idea!  And thanks for creating this bug, as a vehicle for expressing it.

One refinement... The initial part of the value should be shown as well as the field names, to help the user correlate the fields with what they filled out.  The field names could be gibberish created by a programmer or form generator, of course.
This is the same problem as 222589, with the additional twist that saving multiple password fields on a form (which is a uncommon use case) would be hard to distinguish from a change-password form (which is a common use case).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 222589
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.