bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Schema mismatch for version field

RESOLVED DUPLICATE of bug 9352

Status

()

Bugzilla
Bugzilla-General
RESOLVED DUPLICATE of bug 9352
18 years ago
6 years ago

People

(Reporter: Boris Boehlen, Assigned: justdave)

Tracking

Details

(Reporter)

Description

18 years ago
The schema for the "bugs" table uses another definition for the version field
than the table "versions". In the "bugs" table a version is "varchar(16)" and in
the versions "table" it is "tinytext". As a result invoking the santity checks
report an error.

Comment 1

18 years ago
The editversions.cgi limits the Version to 64 characters in the HTML input 
code. Therefore the versions.value fields could be up to 64 chars long. The 
version info stored for each bug in bugs.version can only hold 16 chars.

This causes a problem in process_bug.cgi where it checks if the version has 
changed.

    my $vok = lsearch($::versions{$prod}, $::FORM{'version'}) >= 0;

Because $::FORM{'version'} has been truncated to 16 chars it may not match 
against the 64 char values in the version cache.

If your bug is in a version that is over 16 chars long then the process_bug.cgi 
will complain about a changed product every time the bugs is changed. Quite 
annoying. 

I guess I am going to shorten my versions down to 16 chars.

The solution to this is to rationalise the size of the version field.

Comment 2

18 years ago
schema issue
Assignee: tara → cyeh
Whiteboard: 3.0
Moving to real milestones...
Whiteboard: 3.0
Target Milestone: --- → Bugzilla 3.0
Taking all Bugzilla 3.0 bugs -- congratulations to MattyT for the triage, it
really was spot on. Note: I may end up pushing some of these bugs back to 3.2,
we'll see. However, I believe all these bugs should just fall out of the 
redesign. Let's hope I'm right!

(Note: I'm also resetting the priority field to "---" so that I can retriage any
that I consider important or likely to be dropped.)
Assignee: cyeh → ian
Component: Bugzilla → Bugzilla 3
Priority: P3 → --


*** This bug has been marked as a duplicate of 9352 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Component: Bugzilla 3 → Bugzilla
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 3.0 → Bugzilla 2.14
clearing milestone on closed non-FIXED bugs in case they ever get reopened.
Target Milestone: Bugzilla 2.14 → ---
moving all closed Bugzilla bugs to the new Bugzilla product.
This batch is DUPLICATE/INVALID/WORKSFORME/WONTFIX
reassigning to default owner and QA in case of the bug being reopened.
Clearing milestones, since we really shouldn't have them on these types of
resolutions.  Sorry for the spam everyone...
Assignee: ian → justdave
Status: RESOLVED → NEW
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.