Bookmarks Toolbar folder not removable

VERIFIED INVALID

Status

()

Firefox
Bookmarks & History
VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: Lockser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

The Bookmarks Toolbar folder cannot be deleted in Firefox 3b5.

In Firefox 2 the folder could be deleted by setting a new folder as the Toolbar folder. Fx3 has no option to do this.

Reproducible: Always

Steps to Reproduce:
1. Click on Bookmarks
2. Right-click on "Bookmarks Toolbar"
3. Observe that "Delete" is greyed-out
4. Click on Organise Bookmarks
5. Observe that there is no option to alter the toolbar folder


Expected Results:  
Offered a way to set a new folder as the Bookmarks Toolbar folder allowing the original Bookmarks Toolbar folder to be deleted.
That is by design.  The Bookmarks Toolbar Folder is considered one of the 'root-folders' used by the Library and thus cannot be deleted. 

https://bugzilla.mozilla.org/show_bug.cgi?id=405237

Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.