All users were logged out of Bugzilla on October 13th, 2018

temporarily freezes on startup and every couple hours

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
11 years ago
10 years ago

People

(Reporter: mark.seymour, Unassigned)

Tracking

3.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

On startup of Firefox 3b5, and subsequent hours (possibly?), Firefox appears to freeze, and I am certain that it is checking for new entries in my RSS feeds.  I have about 45 feeds stored in an "RSS" folder.

Reproducible: Always

Steps to Reproduce:
1. Have at least 10-20 RSS feeds stored, sites like Slashdot, Techcrunch, but it doesn't matter (I am uncertain whether a low amount of rss feeds would work)
2. Shut down firefox, wait for the process to stop.
3. Start firefox, and especially if it has to download data, it should temporarily freeze.
4. Use for around 4-5 hours, and just browse around; it may or may not freeze for about half a minute to a minute
Actual Results:  
Firefox becomes unresponsive while it downloads RSS feeds.
It's also possible that it may be doing something else, but I am uncertain.

Expected Results:  
It should have done it in a background process (or thread?) making the browser more reliable to the end user.

Extensions loaded:
4chan, Dom Inspector, DownThemAll!, FAYT, Fission, Glasser (http://forums.mozillazine.org/viewtopic.php?p=3343435), Hide Menubar, IE Tab, OPML Support, Stop-or-Reload Button, Stylish, URL Fixer, ViewSourceWith, Web Developer.

My computer has Dual-core Pentium, 1.73GHz/core, 2GB memory; Toshiba Satellite A100-wa3
(Reporter)

Comment 1

11 years ago
I just tested Fx3b5 with no addons mode, and I have not encountered this problem; it could be a problem with one of my addons, so I will keep this as unconfirmed, until someone can identify the source of this problem (which is more than likely a problem with one or more of my addons, but I cannot be sure.)

Comment 2

11 years ago
It's might also be the safebrowsing / malware database (urlclassifier3.sqlite). Firefox 3.0 RC1 will have some improvements compared to the latest beat 5.
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> It's might also be the safebrowsing / malware database (urlclassifier3.sqlite).
> Firefox 3.0 RC1 will have some improvements compared to the latest beat 5.

Maybe that could be it. For now I'll keep it as unconfirmed.
(Reporter)

Comment 4

10 years ago
An update: 

I still get this problem on Firefox 3.0.1 start up.  
If I am correct, Firefox checks the server that contains the blacklist and checks to see if it has an update, right?  There are times when I start up Firefox and it does not freeze.  Most of the time it does.  It usually remedies itself within a minute. I also am seeing this freeze-up on my family's Windows XP Home computer.
(Reporter)

Updated

10 years ago
Severity: enhancement → normal
(Reporter)

Updated

10 years ago
Component: General → Phishing Protection
Version: unspecified → 3.0 Branch
(Reporter)

Comment 5

10 years ago
I have not noticed this problem for quite some time now, at least since I've had this new computer for 5 months now.

Marking it as resolved and fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 6

10 years ago
I am glad your issue has been resolved, but that makes this bug WORKSFORME. FIXED is only for a bug that has had a known patch checked into the tree, which has not happened in this case.
Status: RESOLVED → VERIFIED
Component: Phishing Protection → General
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.