Closed Bug 43304 Opened 22 years ago Closed 22 years ago

'quit' in 'manage bookmarks' kills all Mozilla windows

Categories

(SeaMonkey :: General, defect, P3)

x86
Windows 95

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 39057

People

(Reporter: spasemunki, Assigned: bdonohoe)

Details

Builds: MS 16 (ID 2000061311), nightly as of 6/21/00 (ID 2000062020)
Steps to reproduce:
1)Open as many Mozilla windows as you like
2)Select the 'manage bookmarks' option from the Bookmarks menu
3)From the file menu of the manage bookmarks dialog, select the quit option
Results:
All Mozilla windows close
Expected Results:
My guess is that you would expect the dialog window to close.  There is already
a close option from the file menu; killing every open window seems like more
than you would want from a button on a single dialog, particularly since the
quit button is at the bottom, and is much more visable than the close option.
Maybe it's a feature, but it seems unlikely to me that a user is going to want
to shut down the whole program from a bookmark dialog.  I would say that the
'close' option needs to be removed from the menu, or rewired to close at most
the current window.
As much as I know, quit means kill. Maybe it should say "exit" and exit the
bookmarks menu.
Right, 'quit' consistantly means kill in the other menus.  But none of the other
dialogs or pop ups (prefs, view source, etc.) has an option to quit.  There
needs to be a more readily apperant way of leaving the manage dialog, and
probably not an option to kill.
The bookmarks manger is not a simple 'dialog' it is an XP App, just like the Addressbook, or mail for that matter. Like all of 
those apps and any browser window you open it has a 'close' and a 'quit' under the file menu. Each of those commands 
correspond to standard actions, close closes 'this' window and quit quits the app.

You want to remove the 'Quit' option? So you have to recall another window to leave the app?
You want something more readily apparent than File|Close to close the window?

Left unto my own i would resolve this as invalid, but every design suggestion has some merit so I'm moving this to where it 
belongs. UI: Design feedback.
Assignee: slamm → bdonohoe
Status: UNCONFIRMED → NEW
Component: Bookmarks → User Interface: Design Feedback
Ever confirmed: true
QA Contact: claudius → mpt

*** This bug has been marked as a duplicate of 39057 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
Verified dup.
Status: RESOLVED → VERIFIED
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.