generated code is not executable and crashes

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: dvander, Unassigned)

Tracking

Details

Attachments

(1 obsolete attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: 

I went to run TT on a simple "hello world" script and it crashed.  This looks like the cause of bug 432683, but I filed a new one since it is more specific (and I'm unable to test on Windows right now).  Nonetheless it will indeed crash DEP since nMarkExecute() is not implemented.  Similarly it'll crash Linux systems that have NX-bit support.

Reproducible: Always

Steps to Reproduce:
Get tamarin-tracing to run a hot path (generated code) on a system with the NX bit being enforced.
Actual Results:  
Segfault

Expected Results:  
Shouldn't segfault
Created attachment 320299 [details] [diff] [review]
proposed fix

I tested that it compiled on Windows but I can't test that it fixes bug 432683 (DEP crashing) with my computer.

Updated

11 years ago
Attachment #320299 - Flags: review?(rreitmai)

Updated

11 years ago
Attachment #320299 - Flags: review?(rreitmai) → review+
Comment on attachment 320299 [details] [diff] [review]
proposed fix

pushed
Attachment #320299 - Attachment is obsolete: true
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.