Internet Search from the toolbar search field doesn't work; entering nor clicking the search icon works.

RESOLVED WORKSFORME

Status

()

Firefox
Search
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Carol Sanders, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5

When typing a search string in the Internet search toolbar in the top right of the window and hitting enter or clicking the search icon yield no result.

Reproducible: Always

Steps to Reproduce:
1.Open browser
2.type word or text to search in Internet search bar
3.Hit enter or search icon
Actual Results:  
no results, no pages are listed, page remain blank

Expected Results:  
list of sites of interest from search criteria
(Reporter)

Updated

10 years ago
Summary: Internet Search from the toolbar search field doesn't work; enter or clicking the magnifier icon doesn't work. → Internet Search from the toolbar search field doesn't work; entering nor clicking the search icon works.
Can you set:
browser.search.log
and
javascript.options.showInConsole

to true using about:config, then restart Firefox and post any relevant error console errors/messages here?

Comment 2

10 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008070400 SUSE/3.0.1-0.1 Firefox/3.0.1

I'm seeing the same problem with FF 3.0.1. The first few searches (generally three, although I'm not sure it's consistent) from the search toolbar work each time I start FF, but then it stops working--Enter and clicking the search engine do nothing.

I enabled the about:config options listed above, but nothing incriminating shows up. After the startup log messages, the following log messages appear when searching for "foo", "bar", "baz", and "bam" in succession:

 *** Search: getSubmission: In data: "fo"
*** Search: getSubmission: Out data: "fo"
*** Search: getSubmission: In data: "foo"
*** Search: getSubmission: Out data: "foo"
*** Search: getSubmission: In data: "foo"
*** Search: getSubmission: Out data: "foo"
*** Search: getSubmission: In data: "bar"
*** Search: getSubmission: Out data: "bar"
*** Search: getSubmission: In data: "bar"
*** Search: getSubmission: Out data: "bar"
*** Search: getSubmission: In data: "baz"
*** Search: getSubmission: Out data: "baz"
*** Search: getSubmission: In data: "bam"
*** Search: getSubmission: Out data: "bam"

Searches for "foo", "bar", and "baz" worked, but "bam" did not.

This may be a profile corruption bug--I've had problems recently that forced me to delete my profile.sqlite* files to get my bookmarks back.

Comment 3

10 years ago
Confirmed that this works in another profile, and that it seems to be consistently failing after the third search toolbar search (the third one works, the first one doesn't).

Comment 4

10 years ago
I started having this problem very recently as well.  A clean profile did not have the problem.  It turns out, I had both the Speed Dial and Fast Dial add-ons enabled at the same time.  Disabling one or the other (and having only one running) consistently fixed this problem.  I would be able to type text into the search field, but pressing enter or clicking the search icon would do absolutely nothing.

Comment 5

9 years ago
I just upgraded to FF 3.1b2 and have been experiencing this problem since the upgrade, except that it fails from the first try (i.e. never works)

Comment 6

9 years ago
I just tried removing then reinstalling, didn't help.  Deleting search.sqlite also didn't help.

Using a fresh profile did help.  I don't was it an extension? corruption? don't know at this point..
If you have the old profile please give it a try by starting Firefox in Safe Mode. Do you have one of the add-ons installed which were mentioned above?
Version: unspecified → 3.0 Branch

Comment 8

9 years ago
I do still have the old profile and did try safe mode with it, no joy.

This evening at home I tried but did not experience this problem.  However, I tried with beta v3, so I'll try that tomorrow at work, where I had the problem.
Ok, so one idea. If no add-on is responsible for this behavior please move the formhistory.sqlite temporarily away from this profile while Firefox is not running. Does it solve your problem?

Comment 10

9 years ago
that did the trick; thanks!  Would a copy of the problem file be of any use for tracking down this bug?  What do I lose by deleting that file?
Shi, which version are you using? Can you try it with Firefox 3.0.7 and Firefox 3.1b3? Fail both or only the 3.0.7? It should only be 3.0.7.

Carol, does my hint from comment 9 also help you?
Flags: blocking-firefox3.1?
Flags: blocking-firefox3.1?

Comment 12

9 years ago
I thought I posted a reply a few days ago, but I guess it didn't take..

I see no problem with 3.0.7, even with the problem version of formhistory.sqlite.  I confirmed a problem with the 'corrupted' formhistory.sqlite, when using 3.1b2.  Please let me know if there is anything else you'd like me to try with 3.1b2 before I update to 3.1b3.

Comment 13

9 years ago
I got tired of waiting, and upgraded to 3.1b3.  The 'corrupted' formhistory.sqlite no longer causes this problem, unless the upgrade process actually replaced it..
Shi, could you do me a last favor? Can you run a tomorrows nightly build on 1.9.0 branch and check if it works now with the broken formhistory.sqlite? It should be fixed now on the 1.9.0 branch. Look for a 03/18 folder here:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2009/03/

Carol, please report back too. When Shi can verify the fix we will close this bug.

Comment 15

9 years ago
Just tested - not only does 3.0.8 work with the corrupted formhistory.sqlite, but after running this test even 3.1b2 worked (first I copied in my corrupted version and verified that 3.1b2 was not working), so it must do something to repair the corruption.  Will now test to see if 3.0.7 does the same...

Comment 16

9 years ago
Okay: 3.0.7 does NOT repair formhistory.sqlite in the same way.  3.1b3 does.

procedure:
1. copy corrupted version to profile/formhistory.sqlite
2. run 3.1b2, confirm that problem exists
3. run candidate for testing (3.0.7, 3.0.8, 3.1.b3), type something into the search bar & press Enter
4. repeat step 2, check whether problem still exists
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.