Google Maps leaks when NoScript is installed

RESOLVED WORKSFORME

Status

()

Core
DOM
P1
normal
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({mlk})

Trunk
Points:
---
Bug Flags:
wanted1.9.0.x +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Google Maps leaks when NoScript is installed.  (It seems very particular to Google Maps -- I use NoScript and I use leak-gauge, and Google Maps is basically the only site I see leaking.)

Steps to reproduce:
1. create a clean Firefox profile
2. install NoScript 1.6.5 from https://addons.mozilla.org/en-US/firefox/addon/722
3. restart Firefox with that profile to get extension installed
4. start Firefox with that clean profile and with NSPR_LOG_MODULES=DOMLeak:5,DocumentLeak:5,nsDocShellLeak:5,NodeInfoManagerLeak:5 NSPR_LOG_FILE=nspr.log in the environment and http://maps.google.com/ as the command line URL argument
5. run leak-gauge on nspr.log

Actual results:
Leaked inner window 1bdd260 (outer 120dda0) at address 1bdd260.
 ... with URI "http://maps.google.com/".
Leaked outer window 120dda0 at address 120dda0.
Leaked content nodes associated with node info manager at address 1bc3d80.
 ... with document URI "http://maps.google.com/".
Summary:
Leaked 2 out of 11 DOM Windows
Leaked 0 out of 40 documents
Leaked 0 out of 6 docshells
Leaked content nodes within 1 out of 49 documents

Expected results:
no leaks
(Reporter)

Comment 1

10 years ago
Note that I first noticed this in a build that I shut down at or before 2008-04-14 00:36:48 -07:00 (which is the timestamp I have on the leak-gauge output).  I'm not sure if the regression was due to Firefox build changes or NoScript extension changes.
Created attachment 320387 [details]
leak log

confirmed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008050621 Firefox/3.0pre using NoScript and Google Maps (the current popular UNOSAT Myanmar (Burma) Cyclone Map in this testcase)

 => mAllocCount:          54861
 => mReallocCount:         7988
 => mFreeCount:           52425  --  LEAKED 2436 !!!
 => mShareCount:          53880
 => mAdoptCount:           5806
 => mAdoptFreeCount:       5803  --  LEAKED 3 !!!

Updated

10 years ago
Keywords: mlk
OS: Linux → All
Hardware: PC → All
Flags: wanted1.9.0.x+
Priority: -- → P1

Updated

9 years ago
Duplicate of this bug: 450870

Comment 4

9 years ago
Not reproducible on NoScript 1.8.9.9 and
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2a1pre) Gecko/20090129 Minefield/3.2a1pre ID:20090129033611
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.