Closed Bug 433216 Opened 12 years ago Closed 12 years ago

Clear Private Data should have an option to clear current session history only

Categories

(Firefox :: Bookmarks & History, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 453440

People

(Reporter: 427384, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051011 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051011 Minefield/3.0pre

Given that Firefox now keeps browsing History for a long period by default and uses it to search in the location bar, clearing the entire browsing history has more serious consequences than it did previously. Therefore, Clear Private Data should provide an option to clear the current session's history only.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Similar to bug 248970, although that requires you to start the private browsing mode before you surf. The advantage would be that the data never touched the hard disk, so it can not be recovered afterwards.

PS : clearing recent history is one thing, but your cookies will contain the data that was collected today. You can't rollback to the previous version, unless there's some kind of profile-restore.
Component: History → Bookmarks & History
QA Contact: history → bookmarks
OS: Windows XP → All
Hardware: PC → All
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 453440
You need to log in before you can comment on or make changes to this bug.