Bookmark icon is replaced if a 404 error occurs after clicking it

RESOLVED DUPLICATE of bug 350440

Status

()

RESOLVED DUPLICATE of bug 350440
10 years ago
10 years ago

People

(Reporter: martinridd, Unassigned)

Tracking

2.0 Branch
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-GB; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-GB; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

If a bookmarked site is visited when it is temporarily down and a firefox error page (e.g. "Server not found") is displayed; the icon on the favourite menu is replaced with the icon of the site you where on before clicking the bookmarked link.  After this, the incorrect icon will be allocated to that bookmark permantely.

Reproducible: Always

Steps to Reproduce:
1. Create a favourite to a URL that will produce a firefox error page (e.g. http://www.wkjshdfkjsdhklajsdfh.com/) (this is to simiulate an actual bookmark, if a site is temporarily unavailable)
2. Visit another website with a web icon (e.g. http://www.mozilla-europe.org/en/)
3. Select the favourite icon created in Step 1
Actual Results:  
4. The icon of the website visited in Step 2 will be assigned to the bookmark created in Step 1

Expected Results:  
The icon should not be added to the bookmark.
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0 Branch

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 430792

Comment 2

10 years ago
430792 was a recent trunk regression; I think 350440 fits better here. :)
Duplicate of bug: 350440
You need to log in before you can comment on or make changes to this bug.