"No proxy for" wrongly interpretes a dash in a domain name

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: mouriskippy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

I'm working for a company called let's say  XYZ.
From inside our network, we can access the company internet site xyz.com and its subdomains (news.xyz.com , sports.xyz.com  ...) without using the proxy server. This is defined by putting XYZ.com in the "No proxy for" field. So far, everything works great.

Now, I'm the webmaster of a private website called  abc-xyz.com . It is independent from the company, but the characters after the dash are the same than our company name !
With Firefox, I cannot access my private internet site from within our company network. 

On my PC, I worked around the problem by simply taking out the 'xyz.com' from the "No proxy for" field.
But as other people in our company simply import those settings from their IE, they can't access my pages and just get a message that the server takes too long to respond. As I can't control what other people have in their "no proxy for" field,
Firefox should recognize abc-xyz.com as a different domain name. For the moment, it seems to be considered as part of the domain xyz.com


Reproducible: Always

Steps to Reproduce:
1.Put  xyz.com  in the "No proxy for" field
2.Browse to the internally reachable website xyz.com
3.Browse to an also existing, but foreign domain abc-xyz.com
Actual Results:  
xyz.com could be correctly reached on the internal network without using a proxy.
abc-xyz.com cannot be reached.

Expected Results:  
Reach xyz.com without proxy.
Reach abc-xyz.com through the proxy.

Neither with Internet Explorer nor with Netscape 8, installed on the same PC and using the same proxy settings, this problem appears.

Comment 1

11 years ago
It has nothing to do with the dash. Firefox just uses a straight comparison (starting from the right hand side).

http://www.mozilla.org/quality/networking/docs/aboutno_proxy_for.html

Workaround: filter on .xyz.com
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

11 years ago
Hi Jo,


I agree that the dash is not the problem. But I'm sorry, I cannot agree with the fact of straight comparison. Please let me do 2 comments about this :
In particular, for me, this is a bug. I have a work-around, but I can't influence the settings of other people in our company, who simply take the settings delivered by our IT department. As long as other people can't reach my site, a work-around for myself doesn't help. So this should not be declared as fixed, but the problem should be corrected.

In general, a proxy server has to deal with IP addresses and domain names. So the browser should handle the proxy settings accordingly, and not make a text-related comparison from right to left. It is unthinkable that one site cannot be reached just because another domain has accidentally the same last characters ! The proxy settings should handle IPs and domains. In order to be flexible, wild-chars should be supported, and in order to be user-friendly, the settings should be compatible with those of other browsers.

Jean-Paul

Comment 3

10 years ago
Jean-Paul:

There are still a couple bugs that are open, that describe how to implement what you are suggesting... see the document Jo provided.

You can reopen this bug and mark it a duplicate of any of those bugs, if you like.

You need to log in before you can comment on or make changes to this bug.