On a dual screen setup all popup windows show up on the second monitor

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Matěj Cepl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5
Build Identifier: firefox-3.0-0.60.beta5.fc9.i386

(originally filed as https://bugzilla.redhat.com/show_bug.cgi?id=445359)

When hovering over a button or using the typeahead/history feature of the URL
bar the window for the tooltip or typeahead selection show up on the laptop
monitor while firefox is on the external display.  If I move firefox to the
laptop monitor it seems fine.  I just right clicked for spell check and it
happened with that popup window also.

I am not sure if this happens all of the time but once it starts happening the
behaviour is consistent.


Reproducible: Always

Steps to Reproduce:
1.open firefox on the external monitor
2.type something in the url bar or hover over an icon or right click for a
context menu
3.
Actual Results:  
popup windows show up on the laptop screen

Expected Results:  
popup windows show up on the external monitor in the correct location
(Reporter)

Comment 1

10 years ago
Created attachment 320549 [details]
screencast illustrating the issue

This was attached to the original bug in Fedora.

Comment 2

10 years ago
Does this happen when you dynamically add the new monitor and Firefox was already running when there was only one screen?
In this case, does it still happen if you restart Firefox after the second screen is added?

That could be related to bug 403706
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Comment 3

10 years ago
Matej, do  you see this with current trunk (bug 403706 is fixed on trunk)?  Reference comment 2
(Reporter)

Comment 4

8 years ago
That should go to the original reporter of the bug -- johnp already present on this bug (I don't know how to change needinfo here).

Comment 5

8 years ago
Hasn't been an issue for awhile as far as I can remember

Comment 6

8 years ago
WFM per reporter.
(very likely also a duplicate)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: Find Toolbar → General
Product: Toolkit → Core
QA Contact: fast.find → general
Resolution: --- → WORKSFORME
Whiteboard: dupme
You need to log in before you can comment on or make changes to this bug.