Add 3.0 to the Max Ver list now that Fx3 RC1 build 1 is available

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Administration
VERIFIED FIXED
10 years ago
2 years ago

People

(Reporter: Frédéric Buclin, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
Now that I installed Fx3 RC1 build 1, all extensions are marked as incompatible. That's probably because 3.0 is not available as Max Ver on AMO. You should add it. :)
3.0.* was the planned maxVersion for Firefox 3, not sure if there should be both that and 3.0 or just 3.0.*.
I added 3.0.* since it's inevitable and past RC1 we shouldn't be breaking extensions.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 3

10 years ago
Morgamic, the string for Firefox 3 is (Firefox 3.0) which will not match on "3.0.x" so, we also need 3.0 to be added as well. Once you do this, I can blog about it.

Mconnor can confirm
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
3.0 < 3.0.* ?
3.0.* will work for Firefox 3.0

Comment 6

10 years ago
Verified, I was able to install an extension with a MaxVersion=3.0.* into Firefox RC1 successfully. No need to add "3.0" to the appversion list. Yeah!
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Well, we do need to add 3.0 as a minVersion.
(In reply to comment #7)
> Well, we do need to add 3.0 as a minVersion.
> 

Why is this?
We don't allow minVersions to have * in them, and the standard ranges we always encourage are 2.0 - 2.0.0.*, 3.0 - 3.0.*

Comment 10

10 years ago
Spoke with Beltzner about this well to confirm. Indeed, we need 3.0 as a minVersion so, I've added this. Closing.
Verified FIXED
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.