DNS suffixes not parsed when Firefox used on company LAN

UNCONFIRMED
Unassigned

Status

()

Core
Networking
P3
normal
UNCONFIRMED
10 years ago
7 months ago

People

(Reporter: Steve Hassall, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

We have various DNS suffixes - registered through TCP | Properties | advanced | DNS
Firefox seems to ignore these when trying to connect to site.
eg if example DNS suffix "country.com"
If I type in "town" in location bar IE would find the site called "http://town.country.com"
Firefox will not find this site. 
This appears not to be a bug - this behavior was present in Firefox 2. I was slightly disappointed to to still see this "feature"

Reproducible: Always

Steps to Reproduce:
As above - given n details
Actual Results:  
As above

Expected Results:  
As above

I don't know if this is a feature issue, an oversight or a bug - but it renders Firefox as unusable at work despite all the other presentational benefits. I can't quickly navigate between sites by typing in DNS registered friendly names. (As I can with IE)
Not an OS Integration issue... over to General fr triage
Component: OS Integration → General
QA Contact: os.integration → general

Updated

9 years ago
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Version: unspecified → 1.9.0 Branch

Comment 2

9 years ago
This bug has been ignored in Firefox for a while and now still the same behavior in Firefox 3.5.

It has to do with "Append these DNS suffixes (in order)" setting in Windows TCP/IP. Firefox only uses the primary DNS suffix to append to the url, this is wrong.

If I have entered several DNS suffixes such as:
blah.com
hello.blah.com
again.hello.blah.com

And I type in an address such as http://fixit/ firefox should try appending those in roder before telling me the page doesn't exist.

IE does it, Chrome does it, Firefox does not. It has been very frustrating having to use fully qualified names in Firefox when other browser are good in integrating with Windows TCP/IP setting properly.

Please fix, this is log overdue. Here's a post from a while ago describing the same issue:

http://archives.devshed.com/forums/mozilla-98/firefox-dns-suffxes-1052128.html

Thank you!
Denis

Comment 3

8 years ago
I second this!   I can't believe more people aren't voting on this but then again, most people just switch to using another browser when fundamental functionality like this is broken.

FYI, I'm not sure if it matters or not but I have proxy settings enabled.  I've also tried using the browser.fixup.alternate.suffix option as a workaround but this doesn't work.  In my case, the problem is that I type in "wiki" in the browser bar and it should be going to wiki.mycompany.net but instead it automatically goes to www.wiki.com (even though set browser.fixup.alternate.prefix to nothing and browser.fixup.alternate.suffix to mycompany.net).

Strangely, if I add "wiki" to the list of "no proxy" suffixs in Firefox, then when I type in wiki, everything works correctly which makes me think that something is broken when enabling proxy connections.  I've tried disabling the Firefox dnscache and toggling the network.proxy.socks_remote_dns flag but neither helped.

Comment 4

8 years ago
This is an essential feature that is missing. Please set the status to NEW.

Comment 5

7 years ago
Trying this using Firefox v8, just now, while monitoring DNS queries with Wireshark, showed that (at least something causes) [host].[suffix] to be queried for an A (host) record (which returned a usable answer). So, Firefox is issuing the DNS query, at least. No HTTP requests were sent to the IP address specified in the DNS response, though.
It must be something within Firefox's internal network handling code. Some exception which isn't handled, rather than in need of full implementation.
I'm surprised that this bug is still outstanding.

The strange part is that Firefox handles other non-FQDNs just fine (most all DNS queries; anything lacking a trailing dot (for the root zone)).

Someone with access to a real DNS server would have to test this, to pin down the exact symptoms. Sadly, that's not me, at the moment.
Whiteboard: [necko-backlog]

Comment 6

2 years ago
Testing on Firefox 44 on Windows 7. Exact same issue.

Visiting http://mysite works in IE and Chrome, but fails in Firefox.

Visiting http://mysite.domain.co.uk works in all three.

Our DNS suffixes are set to:
- user.ad.domain.co.uk
- ad.domain.co.uk
- domain.co.uk

It doesn't seem to be picking up all the DNS suffixes.
OS: Windows XP → Windows
Hardware: x86 → All
Version: 1.9.0 Branch → unspecified

Comment 7

2 years ago
Is this not a duplicate of bug 91587?
(In reply to Alistair McMillan from comment #7)
> Is this not a duplicate of bug 91587?
Flags: needinfo?(mcmanus)
dont know
Flags: needinfo?(mcmanus)

Comment 10

a year ago
It seems, that Firefox needs / at the end of the hostname, if you do not use FQDN.
E.g. http://mysite/ should work.
You need to log in before you can comment on or make changes to this bug.