typically used js scrolling text message problem in input[type="text"]

VERIFIED FIXED

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: James Lariviere, Assigned: mjudge)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
DESCRIPTION:

Scrolling text, using good ol' javascript, "flash" renders text in an input
[type="text"] then the text disappears.


STEPS TO REPRODUCE:

view test case.

refresh a couple of times for full effect.


ACTUAL RESULTS:

Mozilla renders form text input correctly.
Mozilla renders the "message" text initially than the text message is gone.


EXPECTED RESULTS:

Mozilla should render text, then have the text "scroll" over and over again.
View either NAV4.x or IE5 for expected results.


DOES NOT WORK CORRECTLY ON:

Win98 build 200062020 (6-20-00-m17 nightly build I think)
(Reporter)

Comment 1

18 years ago
Created attachment 10471 [details]
test case

Comment 2

18 years ago
able to reproduce with build 2000062808 on win98

Comment 3

18 years ago
confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 4

18 years ago
Confirming on WinNT tip build made on 2000-06-27.
Bug did NOT occur with Linux tip build, same date...

Reassigning to Browser-General; not an engine bug -
Do not know which component is in charge of scrolling text...
Assignee: rogerl → asa
Component: Javascript Engine → Browser-General
QA Contact: pschwartau → doronr

Comment 5

18 years ago
updating component and setting default owner.
Assignee: asa → jst
Component: Browser-General → DOM Level 0
QA Contact: doronr → desale
No DOM problems here that I can see, the DOM code correctly sets the value and
notifies the text control frame about the value change, I see
mjudge@netscape.com in bonsai all over nsGfxTextControlFrame2 so I'm reassigning
to him.

Oh, and it works for me on linux too, but not on WinNT, weird...
Assignee: jst → mjudge

Comment 7

18 years ago
this may have been related to bug 42178, which was checked in on 6/30 -- 
Prashant can you retest this to see if that fix also fixed this one -- thanks

Comment 8

18 years ago
Beth, this is working perfect now.
I tested it with 2000-07-17-20.

Mozilla renders text as well as it scrolls text over and over again.
The only problem I could not figure out is why text-box is having back 
background.
Well that is not a problem of concern in this bug. As far as bug mentioned 
above, looks like it is fixed.

Comment 9

18 years ago
based on Prashants input, am marking fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 10

18 years ago
verifying: scrolles even better than IE or Net

for the background color: that's what it's supposed to be (set in CSS)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.