Back and Forward buttons disappear when switching between FF 2 and FF 3 Beta 5.

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
--
minor
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Zach Stroh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

When I wish to use a certain addon that is not supported by Firefox 3 Beta 5 (FF3B5) I close the browser, click 'Save and Quit' to save my current web pages, and then open Firefox 2 (FF2). After I am done, I usually switch back to FF3B5 because it seems to be faster over my *awesome* dialup connection. This has only happened to me twice, but sometimes when I close FF2 and open FF3B5, it loads fine, but with no Forward or Back buttons! That end of the Navigation Toolbar just seems to disappear. De-selecting and then re-selecting the Nav bar does not bring it back, nor does resizing the window. Upon restarting FF3B5, the Forward and Back buttons reappear, right as rain. I tried to reproduce the bug, but couldn't with any accuracy whatsoever. Maybe it has something to do with saving the current web pages?

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Open FF3B5, load a couple of pages in different tabs.
2. Close FF3B5, and make sure to click 'Save and Quit' to save the pages.
3. Open FF2.
4. Close FF2.
5. Open FF3B5.
Actual Results:  
Haven't been able to reproduce the bug when I want to, only when I'm doing homework :), but sometimes the Forward and Back buttons disappear.

Expected Results:  
The forward and Back buttons should not have disappeared (I don't think...)
Are the buttons in a non-default position on the toolbar? This is likely a duplicate of bug 426026.
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Are the buttons in a non-default position on the toolbar? This is likely a
> duplicate of bug 426026.
> 
It is close, but this bug involves no previous toolbar customization- all toolbars are visible, and the buttons are non-existent (from what I could find).
(Reporter)

Comment 3

10 years ago
Update: this seems to be happening to my friend as well, so I know I'm not alone.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 417421
(In reply to comment #4)
> *** This bug has been marked as a duplicate of bug 417421 ***

Jan, did you read comment 2? I think it's still likely that this is a duplicate of bug 417421, but we should get more information before assuming that that is the case.

Zach, do your steps to reproduce in comment 0 involve using a new profile?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 6

10 years ago
No, this does not involve the creation of a new profile, but other than that discrepancy it seems very similar to bug 417421.

As a matter of fact, I have no Forward or Back buttons at the moment. And this time I just started up from a Hibernate and a fresh instance of FF3B5.
(In reply to comment #5)
> I think it's still likely that this is a duplicate of bug 417421

Er, I meant of bug 426026. It's certainly not a duplicate of bug 417421 because that was fixed in beta 5.

(In reply to comment #6)
> No, this does not involve the creation of a new profile, but other than that
> discrepancy it seems very similar to bug 417421.

If you can't reproduce it with a new profile, then it likely is a duplicate of bug 426026. Have you changed the default toolbar layout in any way? Can you reproduce if you "restore default set" in Firefox 2 before step 1?

Comment 8

10 years ago
(In reply to comment #5)

Sorry for duping this one to the wrong bug. Some of the other "dupes" of bug 417421 are from beta 5, too.

(Reporter)

Comment 9

10 years ago
(In reply to comment #7)
> (In reply to comment #5)
> > I think it's still likely that this is a duplicate of bug 417421
> 
> Er, I meant of bug 426026. It's certainly not a duplicate of bug 417421 because
> that was fixed in beta 5.
> 
> (In reply to comment #6)
> > No, this does not involve the creation of a new profile, but other than that
> > discrepancy it seems very similar to bug 417421.
> 
> If you can't reproduce it with a new profile, then it likely is a duplicate of
> bug 426026. Have you changed the default toolbar layout in any way? Can you
> reproduce if you "restore default set" in Firefox 2 before step 1?
> 

No, this does not involve any toolbar customization, however, after a couple of trials, restoring the default layout does seem to bring the buttons back. They even stay after a few restarts. I may have changed the default layout of the toolbars and just don't remember- but I have only been running Beta 5 for a couple of weeks.

Comment 10

10 years ago
I'm having a similar issue. The back and forward buttons are not in the toolbar when I open FF. I have to add them using the customize toolbar feature.
(Reporter)

Comment 11

10 years ago
To the best of my knowledge, the bug has been resolved with the most recent update to Firefox 3. I haven't had a problem since then. To get the buttons to come back and then STAY back, I just used the "Restore Default Set" button on the toolbar customization dialog.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.