"Reviews" RSS feeds only contains non-linked review-date entries

VERIFIED FIXED in 3.4.2

Status

--
major
VERIFIED FIXED
11 years ago
3 years ago

People

(Reporter: stephend, Assigned: wenzel)

Tracking

({regression})

3.4.2
regression

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Created attachment 320649 [details]
Screenshot of RSS feed for "Reviews"

On both production and preview, the "Reviews" RSS feeds only contains dates.

Steps to Reproduce:

1. Load https://preview.addons.mozilla.org/en-US/firefox/reviews/display/3481
2. Click on the blue RSS icon in Minefield
3. That should've loaded https://preview.addons.mozilla.org/en-US/firefox/reviews/display/1865/format:rss

Expected Results:

Since this is (sadly) broken on production too, I can't test against it, but it should probably have a linked date on each review, at the least

Actual Results:

Just a listing of the review dates, none of which are clickable
(Assignee)

Updated

11 years ago
Keywords: regression
Target Milestone: --- → 3.4.2
(Assignee)

Comment 1

11 years ago
Created attachment 320705 [details] [diff] [review]
Fix translations in reviews RSS feed

I apparently forgot to fix the RSS feed when I wrote the code to display reviews in all languages. Thanks for finding this, stephend!
Assignee: nobody → fwenzel
Status: NEW → ASSIGNED
Attachment #320705 - Flags: review?(fligtar)
Comment on attachment 320705 [details] [diff] [review]
Fix translations in reviews RSS feed

Looks good.
Attachment #320705 - Flags: review?(fligtar) → review+
(Assignee)

Comment 3

11 years ago
Thanks, r13103.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: push-needed
Resolution: --- → FIXED
(Reporter)

Comment 4

11 years ago
Verified FIXED; awesome turnaround, Fred, thanks!
Status: RESOLVED → VERIFIED

Updated

11 years ago
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.