The default bug view has changed. See this FAQ.

Plugin finder service doesn't ask to install Java

RESOLVED WONTFIX

Status

()

Core
Plug-ins
P3
major
RESOLVED WONTFIX
9 years ago
3 years ago

People

(Reporter: Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m), Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
blocking1.9.1 -
wanted1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051206 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051206 Minefield/3.0pre

I completely uninstalled Java. After doing this, I simply noticed Firefox 3 doesn't ask user to re-install the missing plugin. Firefox 2 works as expected.

Reproducible: Always

Steps to Reproduce:
1) If you don't have it, install Java Runtimes
2) Uninstall all Java Runtimes and /or Development kits
3) Visit a page that requires Java, as:
http://processing.org/learning/3d/lights1.html
http://www.schubart.net/rc/
Actual Results:  
Firefox 3 doesn't alert for missing plugin at all. Any Java applet is simply not showed at all.

Expected Results:  
Firefox 3 should alert for missing Java plugin.

Tested with new and clean profiles. In about:plugins no Java plugin is listed, in Firefox 2 and 3.
Created attachment 320703 [details]
[Fx2 - Working] Java plugin test - screenshot
Created attachment 320704 [details]
[Fx3 - NOT Working] Java plugin test - screenshot
Attachment #320703 - Attachment description: [Working - Fx2] Java plugin test → [Fx2 - Working] Java plugin test - screenshot
Attachment #320704 - Attachment description: [Fx3 - NOT Working] Java plugin test → [Fx3 - NOT Working] Java plugin test - screenshot
Version: unspecified → Trunk
Just a thought, but by chance did you have the Java 'Disabled' in Tools->Addons->plugins ?

I believe its a known issue if the plugin is 'disabled' it will not prompt you again. 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008051206 Minefield/3.0pre Firefox/3.0 ID:2008051206
As I said, there's no Java plugin listed in about:plugins. Before the Java Runtime uninstallation, the plugin was enabled. And I tested the bug in clean profiles.
At the official Java page:

http://www.java.com/en/download/installed.jsp?detect=jre&try=1

the plugin service reports that Java is not installed. The previous reported url still not work.

Do you have other pages with Java contents I can test?

Comment 6

9 years ago
Confirmed on OS-X as well. Marking as confirmed.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008053008 Firefox/3.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 7

9 years ago
I can confirm the problem.
OS: All → Windows XP
Hardware: All → PC
Haider, Hasham in Comment #6 confirmed the problem on OSX, so the bug can be marked as OS: all and Hardware: all.

Added blocking request flags.
Flags: blocking-firefox3?
Flags: blocking-firefox3.1?
OS: Windows XP → All
Hardware: PC → All

Comment 9

9 years ago
Yep, changes OS to all and hardware to all.
Not going to block Firefox 3.0, but we might take a patch with tests on the stability branch.

Mossop: any ideas?
Flags: blocking-firefox3? → blocking-firefox3-
At a guess it is because the website is using a plain applet tag rather than object which Sun have been advocating in preference now for some time.
Component: Plugin Finder Service → Plug-ins
Flags: blocking-firefox3.1?
Flags: blocking-firefox3-
Product: Firefox → Core
QA Contact: plugin.finder → plugins
Resetting blocking flag
Flags: blocking1.9.1?
Seems unlikely to uninstall java without installing a new version instead.
Flags: wanted1.9.1+
Flags: blocking1.9.1?
Flags: blocking1.9.1-
Priority: -- → P3
I don't know if this bug happens on a pc you never installed Java, but I think it's greatly probable.
Summary: [Fx3] If Java will be uninstalled, plugin finders service doesn't ask to reinstall it → [Fx3] If Java is uninstalled, plugin finder service doesn't ask to reinstall it
Keywords: qawanted
Whiteboard: [reproducible if Java is never installed?]
Summary: [Fx3] If Java is uninstalled, plugin finder service doesn't ask to reinstall it → Plugin finder service doesn't ask to install Java (only if Java is previously uninstalled?)

Comment 15

9 years ago
I just tried it on virtual mashine with clean XP and java never installed.
the result is that there is no warning on http://processing.org/learning/3d/lights1.html .
On http://www.schubart.net/rc/ the webpage write: "Sorry, it seems that Java is disabled on your system or not supported by your web browser." 
Thanks Haider.
Keywords: qawanted
Summary: Plugin finder service doesn't ask to install Java (only if Java is previously uninstalled?) → Plugin finder service doesn't ask to install Java
Whiteboard: [reproducible if Java is never installed?]
Bug 836415 has now removed the Plugin Finder Service (PFS) from Firefox. As a result, I'm closing all the remaining PFS bugs.

If you're getting this bugmail for an ancient PFS bug, the basic summary of the world today is:

* NPAPI plugins are a dying technology
* PFS was already restricted to assisting with only the 4 most common plugins
* Sites commonly provide their own UI for install a required plugin
* Mozilla is generally focusing on  improving the web platform so that proprietary plugins are not required.

(Note that "plugins" are a completely separate from "browser extensions", such at those found on addons.mozilla.org. The latter are not going anywhere, and are not impacted by the removal of PFS.)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.