Need new icon for Shredder builds

RESOLVED FIXED in Thunderbird 3.3a1

Status

Thunderbird
General
--
minor
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: davida, Assigned: andreasn)

Tracking

Trunk
Thunderbird 3.3a1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(21 attachments)

22.44 KB, image/png
Details
30.44 KB, image/png
Details
8.92 KB, image/png
Details
67.71 KB, image/png
Details
22.27 KB, image/png
Details
23.42 KB, image/png
Details
26.28 KB, image/png
Details
25.91 KB, image/png
Details
18.66 KB, image/png
Details
56.17 KB, image/png
Details
29.93 KB, image/jpeg
Details
26.39 KB, image/png
Details
233.91 KB, image/png
Details
173.95 KB, image/svg+xml
Details
79.43 KB, image/svg+xml
Details
344.50 KB, image/svg+xml
Details
193.00 KB, image/svg+xml
Details
185.92 KB, image/png
Details
11.96 KB, image/png
Details
15.98 KB, image/png
Details
412.08 KB, patch
clarkbw
: ui-review+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
Attach suggested designs to this bug.
Flags: wanted-thunderbird3.0a2+

Comment 1

10 years ago
Created attachment 320964 [details]
round scissor 1 -shredder icon

Please indulge, take as draft, needs refinement ..

Comment 2

10 years ago
Created attachment 320965 [details]
scissor bird 1 -shredder icon

Please indulge, draft ... really unpolished ..
(Derived from scissor ..)

Comment 3

10 years ago
Created attachment 321000 [details]
Shredder Alpha icon suggestion... 
Equally rough and ready...

Updated

10 years ago
Attachment #321000 - Attachment description: Shredder Alpha icon suggestion... → Shredder Alpha icon suggestion... Equally rough and ready...
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> Created an attachment (id=321000) [details]
> Shredder Alpha icon suggestion... 
> 

That one is too subtle a change from the Tb icon.  In general, I want something _very_ different, and scary.
(Reporter)

Comment 5

10 years ago
(In reply to comment #1)
> Created an attachment (id=320964) [details]
> round scissor 1 -shredder icon
> 
> Please indulge, take as draft, needs refinement ..
> 

I like that one better than your second one, because it's very visibly different and doesn't really echo the main brand.  I would be happier w/ something even further away.  For example, maybe no blue.
Created attachment 321013 [details]
Minefield inspired like approach

I'm not even sure I like this, but thought I'd throw the idea out there.
(Reporter)

Comment 7

10 years ago
(In reply to comment #6)
> Created an attachment (id=321013) [details]
> Minefield inspired like approach
> 
> I'm not even sure I like this, but thought I'd throw the idea out there.
> 

wesley: given that it's called shredder, I don't think a bomb is appropriate, even though that made sense for minefield =)

Comment 8

10 years ago
Created attachment 321055 [details]
round scissor 2 red-gray -shredder icon

maybe red is more for alarm... hm

Comment 9

10 years ago
Created attachment 321057 [details]
just shredder

kinda ugly design for the machine .. well ..

Comment 10

10 years ago
Created attachment 321058 [details]
warning sign

more like it. About red, warnings, far from original ..

Comment 11

10 years ago
I'm not sure about not using blue, if the icon is too much not thunderbird using nightlies can be deterring. (And we really hope not to be real shredders of nightly profiles.)

Attachment 320965 [details] is quite nice, though it may be too similar... :)
Blocks: 397621

Comment 12

10 years ago
Created attachment 321067 [details]
warning sign 2 variation -mean envelope

warning sign variation
the envelope looks meaner and adds devil like cutout image (with those corners)

Comment 13

10 years ago
Created attachment 321068 [details]
moz scrach

moz scratching envelope. More mozilla, has a 3 (III) in image, but not refined, just the idea. 

The more explicit version would have mozilla-godzilla head and hand scraching III on envelope ...

Comment 14

10 years ago
If the policy in FF is like bug 397621, note the approach:
1. official FFOx icon: Globe with Fox (1/2 yin-yang like..)
2. unofficial alphas : Globe alone (though seams very different, blue etc)
3. minefield : Globe with dynamite (Adds alarm)
that would lead to Tb
1. official TB: Envelope with Bird (1/2, bird is protective...)
2. unofficial alphas : Envelope alone (though seams very different, yellow etc)
3. shredder : Envelope shredded or with a scissor etc (Adds alarm)

Not sure if that is not too much abstraction and philosophy .. Course 2+3 are just suggestions, envelope alone is not a solution. 

The main Idea is that the 2 and 3 should maybe be thought together in this regard. And yes, the envelope can be the cross 123 element, as globe is for FF

[Maybe like in my warning examples, alpha would be envelopes with warning sign or just the circle in the background and nightlies add shreds to envelopes ..]

Does this add more reason to this branding iconing etc ?

Comment 15

10 years ago
Created attachment 321080 [details]
warning variation

variation and also illustration/example of comment 14

Comment 16

10 years ago
@ davida
If there are images sent only to you on mail (as one option on respective blog post) would you please attach them here also? Or if it's time consuming, fwd and I'll help with it. 

Or otherwise ignore this comment, no problem. Really :). Sorry, I'm just thinking there a too few here, this is it? or this is not all? or should be announced on ng also ..

Comment 17

10 years ago
Created attachment 321123 [details]
JPG of rough sketch for Shredder icon

Thought  I'd keep the thunder bird envelope and use the bird claws to represent danger

Comment 18

10 years ago
Created attachment 321471 [details]
first draft 'SHREDDER' 

So I went with an actual shredder(red for DANGER) and wings that look like they can shred....
Created attachment 322775 [details]
Sawblade Icon

This isn't technically a "shredder" but it's the first thing that came to my mind when I heard the name. I just thought of something metal and sharp that could do some serious damage. So I worked one up real quick.
I personally like the first suggestion from attachment 320964 [details] best. I also think that not using blue would go *too* far away from the official branding.
(Reporter)

Comment 21

10 years ago
I agree, of all of these Ovidiu's scissors are the best.  I'm not thrilled about it for some reason, but that's hardly useful feedback.

Ovidiu, do you have time to make a more "refined" version (your words =)? I think the bottom blade looks a little funny in front.  I'm not convinced by the "roundness" of it all -- I think there's no need to stay with a spherical concept. 

Comment 22

10 years ago
OK. Well, the roundness is rather odd or too cartooney for a scissor, but I think I started by replacing the bird with a very much alike element in terms of shape, but surprisingly opposite in effect (protective bird wings vs threat ..) Maybe it's the resemblance to original bird shape that makes it ring... As about the blue, it comes natural on a metallic shine.

Anyway, I'll try some to see if it get's better 

Comment 23

10 years ago
Created attachment 328433 [details]
some revisions

some changes for normalizing shapes. 1 is original, 2 3 some change, extra should ignore (don't think makes sense to variate more ..) As about colors, could do with the blues shifted a bit. like img .. 

My question is, still, how recognizable and clear cut are the shapes? I have them in my head so need fresh viewers. Considering small icons too [128px this]

ps. this is vector svg, inkscape. May use at will, course. But what formats and sizes should eventually produce? Or I shouldn't bother?

Comment 24

10 years ago
Created attachment 328435 [details]
or maybe ..

I was just looking at the win icons that get a left bottom arrow that cover a big chunk ..

Comment 25

10 years ago
Created attachment 329654 [details]
possible schema for home page/about/other graphics

Would it make sense to adapt the Shredder start page/about or other graphics with something like this? (preferably on a white or #ede9ccff background)

Trying to show the "in design" phase etc.. Fonts not appropriate for logo.

Comment 26

10 years ago
Created attachment 329670 [details]
scissor rev 4

Please review and check the following:
-is it better generally?
-the color scheme
-see shapes if readable, especially on small size
-detailed enough/polished enough for bigger pics (may just zoom in, all vectors)
-other?
I had this nice idea for Shredder icons, since I don't like the current envelope. I don't know if this bug is really still open though, and I don't have too much time to completely work it out either (and I don't have a mac), so I'll just drop my idea here for the time being.

If anyone likes the idea, feel free to take up on it...

After reading here I came up with the idea of a blackbird: this has the darkness of mozillamessaging's website in it's name and appearance, plus the darkness of nightlies, and stands close to Mozilla's "lean and mean" philosophy and "aviary" style.

If you add some burnt e-mail messages beind the afterburners, you can even make it more clear that it can be unsafe for your e-mail...

Here's some nice pictures of blackbirds:
http://www.rmrmfg.com/sr71.jpg
http://en.wikipedia.org/wiki/SR-71_Blackbird

Updated

10 years ago
Blocks: 430762
No longer blocks: 430762
Blocks: 451238

Comment 28

10 years ago
It had flag for blocking alpha2 now we are moving to beta2, still no icon chosen.
(In reply to comment #28)
> It had flag for blocking alpha2 now we are moving to beta2, still no icon
> chosen.

Although we've not chosen an icon for the 1.9.1 branch, we have (I believe) decided to retain Shredder as the name for trunk nightlies. I'm planning on trying to drive a new icon set for (at least) the trunk nightlies sometime in the next few months when I get a break from TB 3 items.

Comment 30

10 years ago
clearing wanted‑thunderbird3.0a2 for consistency sake
Flags: wanted-thunderbird3.0a2+
Duplicate of this bug: 483048

Comment 32

9 years ago
(In reply to comment #29)
> I'm planning on
> trying to drive a new icon set for (at least) the trunk nightlies sometime in
> the next few months when I get a break from TB 3 items.

Just a little reminder we still need icon for shredder instead of current generic one.
(Assignee)

Comment 33

9 years ago
Created attachment 418282 [details]
sawblade in envelope

Building upon Stephen's proposal in comment #19

This proposal uses a round object inside a square form, as opposed to the Thunderbird logo that is a square object inside a round form, suggesting the differentiation from regular, stable Thunderbird.

The blade also cuts the envelope open in the bottom, giving the idea that this can break your e-mail, use at risk!

An alternative to the saw blade would be to use a shredder blade, as seen in the logo of Watch it Shred! [1]

1. http://www.ssiworld.com/watch/watch-en.htm
(In reply to comment #33)
> Created an attachment (id=418282) [details]
> sawblade in envelope
> 
> Building upon Stephen's proposal in comment #19
> 

Can we keep it that way ? I like the lack of colors ... Nice !
(Assignee)

Comment 35

9 years ago
Created attachment 420088 [details]
sawblade in envelope v2

here is a draft icon based on the sawblade in envelope sketch, will need a bit more work, but it's getting there.
look great for me :-D
(Assignee)

Comment 37

9 years ago
Created attachment 420553 [details]
sawblade in envelope v3

Still needs some work on the bottom, but getting closer to finish.
(Assignee)

Comment 38

9 years ago
Created attachment 421245 [details] [diff] [review]
all graphics implemented as patch (linux, windows, osx)
Attachment #421245 - Flags: ui-review?(clarkbw)
Attachment #421245 - Flags: review?(philringnalda)

Comment 39

9 years ago
Bryan, any chance you could review this soon?
Comment on attachment 421245 [details] [diff] [review]
all graphics implemented as patch (linux, windows, osx)

Looks fine to me, based on a quick build and glance on Mac, but given the rather minimal amount of code to review, I'll just defer all the reviewing to clarkbw.
Attachment #421245 - Flags: review?(philringnalda)
Comment on attachment 421245 [details] [diff] [review]
all graphics implemented as patch (linux, windows, osx)

Looks good.  The Mac icon doesn't feel quite Mac like enough but the rest are looking in place.
Attachment #421245 - Flags: ui-review?(clarkbw) → ui-review+

Updated

9 years ago
Keywords: checkin-needed
As discussed with Andreas on irc, checked in: http://hg.mozilla.org/comm-central/rev/4a4c56bc1267

(In reply to comment #41)
> (From update of attachment 421245 [details] [diff] [review])
> Looks good.  The Mac icon doesn't feel quite Mac like enough but the rest are
> looking in place.

Andreas will consider this soon, and if so he can do further updates in a different bug.
Assignee: david.ascher → nisses.mail
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.2a1

Comment 43

9 years ago
woo-hoo new icon!
You need to log in before you can comment on or make changes to this bug.