Closed Bug 433692 Opened 12 years ago Closed 2 years ago

Caretmode gets enabled for the whole page is contentEditable is set to false.

Categories

(Core :: DOM: Editor, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: spam, Unassigned)

References

(Depends on 1 open bug, )

Details

(Keywords: testcase)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: 

The caret mode will be enabled for the whole page if you set contentEditable to false on an editable element.

Reproducible: Always

Steps to Reproduce:
1. Open the attached example URL.
2. Place caret inside the editable element.
3. Press the off link to disable contentEditable mode for the element.
4. Notice that the caret mode is now enabled for the whole page.
Actual Results:  
Caret is still visible inside the editable element an also on the whole document.

Expected Results:  
The caret should not be visible at all since there is no editable regions on the page.
Attached file testcase
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
I feel this has a relation with bug 264820, but in this case it's the caret state that needs to adjust to dynamic conditions.
Depends on: 264820
Attached patch mochitestSplinter Review
Mochitest that tests this bug and bug 264820.
I'm asking for blocking on this one. I think it's over due to fix some of the more serious contentEditable bugs.
Flags: blocking1.9.2?
Flags: wanted1.9.2-
Flags: blocking1.9.2?
Flags: blocking1.9.2-
One can work around this issue by calling .blur() before disabling contenteditable
I cannot reproduce this on the latest Nightly 63.  Feel free to reopen this with test case.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.