Email Identity Missing on "email link" clicking & Address Book button, causing Account Wizard to open

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Jim, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: 2.0.0.14

I have been using TB for quite some time without problems. I have 5 different email accounts set up in TB and all have worked fine, without any prior problems. I'm not sure if this is related to the latest update, but I just noticed this yesterday and it has repeated several times from different actions.

1.) I have no problem sending reply emails.
2.) I have no problem if I click on "Write"
3. I have no problem, once I've accessed the Address Book (but note the problem below)

The problem occurs when:
1.) I am in Firefox and click on an email link (this is when problem was first noticed to appear)
2.) I click on the Address Book in TB
3.) I double-click an existing email in my Inbox,
then the following happens:

The Account Wizard "utility" window opens, which states something to this effect:
IDENTITY
Each Account has an Identity
Enter the name you would like to appear in the "From" field of your outgoing messages (i.e. "John Smith")
Your Name [ ] <box for name
Enter your email etc....
Email Address [user@domain.invalid] <this is how box appears

Of course, after clicking Cancel, the Compose window does not have anything in the "To:" or "From:" and the "Contacts" button also does not work.
I have checked all of my account settings for the default & the other email accounts and everything seems to be normal... proper email addresses, smtp settings, etc. (I use the same pop & smtp for all accounts, as they are all on the same server.)

As previously stated, if I click on Write or Reply, everything comes up correctly with the appropriate boxes having the correct info and I can also click on "Contacts" with no problem.

The problem only occurs if I click on the Address Book Icon or click on an Email Address on a webpage or if I double click a message in TB.

Address Book Note: If I click on Address Book, the Account Wizard pops up. I click Cancel and the Address book will work normal, including the ability to click on an individual entry to compose an email, with my Default email in the From: field and the "dropdown" options for my other email addresses.


Reproducible: Always

Steps to Reproduce:
1. Click on email link in Firefox browser OR
2. Double-click an existing email in the Inbox OR
3. Click on Address Book in TB

Actual Results:  
1. TB Email "Compose" window opens with "Account Wizard" window on top
2. Click Cancel on Account Wizard (as it is assumed all account info is correct)
3. No "From:" entry is shown available in the Compose window (does not detect account info) & No "To:" info is shown in the Compose window.

Expected Results:  
1. TB Compose window opens with default "From:" address (and dropdown box for other emails accounts) & "To:" should indicate the email address as it appeared in Firefox browser window. 
 


TB Default Theme 2.0

Add Ons Installed:
Duplicate Contact Manager 0.6
Empty Trash Toolbar Button 0.4
Get all mails 1.0.8
ImportExportTools (Mboximport enhanced) 1.6.1
MoreFunctionsForAddressBook 0.5.1
Purge 0.4
Talkback 2.0.0.9
Unselect Message 1.3 (rev level modified to 2.0.0.14)

All Addons appear to operate properly and have been used for prior TB versions without problems.

Comment 1

10 years ago
Still see it if you disable all extensions? (thunderbird.exe -safe-mode)
Version: unspecified → 2.0
(Reporter)

Comment 2

10 years ago
Well, that led me in the right direction. 
It worked in safe mode. 
I found that there were two extension updates that had not yet installed. 
Get all mails 1.0.9
MoreFunctionsForAddressBook 0.5.1.1

After restarting with the updated extensions, everything appears to be back to normal. 

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 3

10 years ago
->INVALID (FIXED is only used when known code changes resolved the issue)
https://bugzilla.mozilla.org/page.cgi?id=fields.html#resolution
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.