XUL tree content dissapear after 3rd refresh (minimal testcase included)

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Dusan Halicky, Unassigned)

Tracking

3.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-09-15], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008051404 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008051404 Minefield/3.0pre

On included testcase page, there is XUL tree which creating it's content from data received from XMLHttpRequest. When I click and select any item from the tree, after few reloads the content of tree dissapear. On my computer it is allways after 3rd refresh, on FF2 it was after 11th refresh. But it was reproduced on multiple computers.

Bug appeared on FF 2.0.0.14, 3.0beta2, today build, both on windows and linux.

Reproducible: Always

Steps to Reproduce:
1. Open http://komiks.xf.cz/tree/tree2.php
2. Click on the LOAD button
3. With mouse click on e.g. 5th row from tree
4. Click on the LOAD button few times
Actual Results:  
After few reLOADs, the tree content will dissapear. It will appear only when I scroll with mouse wheel.

Expected Results:  
Tree content should be visible always.
(Reporter)

Comment 1

10 years ago
I can confirm this bug IS STILL PRESENT in latest firefox 3.1a1 - Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a1) Gecko/2008072306 Shiretoko/3.1a1
(Reporter)

Comment 2

9 years ago
Finally some change. It still doesn't work but it throws some error at least. I've test it in today Minefield (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081027 Minefield/3.1b2pre) and it shows these 2 messages in debug console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: no]

Fault in cycle collector: zero or overflowing refcount (ptr: 3a8bc40)
(Reporter)

Comment 3

9 years ago
Firefox 3.1 beta 3 - Still doesn't work, but no more exception is displayed, so we are back in pre-3.1beta2 stage
Reporter, are you still seeing this issue with Firefox 3.6.x or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2010-09-15]
Version: unspecified → 3.0 Branch
(Reporter)

Comment 5

7 years ago
Fixed in FF 4.0 beta 4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.