is reference to autoconf-2.13 needed, or should it be autoconf2.13?

VERIFIED DUPLICATE of bug 434075

Status

Firefox for Android Graveyard
General
VERIFIED DUPLICATE of bug 434075
10 years ago
9 years ago

People

(Reporter: Ray Kiddy, Unassigned)

Tracking

Trunk
x86
Mac OS X

Details

(URL)

(Reporter)

Description

10 years ago
I am running on Ubuntu 5.10.

I am following the instructions on the MDC page above. I got the error below. When I changed the client.mk file, and changed "autoconf-2.13" to "autoconfi2.13", it worked fine. Looking at the autoconf man page to see how the mapping works, I do not see a reason we would need to specify "autoconf-2.13". Is there a reason?

It would be trivial, but I could submit a patch if it is desired.

$ !make
make -f client.mk build
Adding client.mk options from /home/ray/mo/try_20080513_184207/mozilla-central/.mozconfig:
    MOZ_BUILD_PROJECTS=xulrunner mobile
    MOZ_OBJDIR=$(TOPSRCDIR)/../mobilebase
set -e; \
        for app in xulrunner mobile; do \
          make -f /home/ray/mo/try_20080513_184207/mozilla-central/client.mk build MOZ_CURRENT_PROJECT=$app; \
        done
make[1]: Entering directory `/home/ray/mo/try_20080513_184207/mozilla-central'
Adding client.mk options from /home/ray/mo/try_20080513_184207/mozilla-central/.mozconfig:
    MOZ_BUILD_PROJECTS=xulrunner mobile
    MOZ_OBJDIR=$(TOPSRCDIR)/../mobilebase
Generating /home/ray/mo/try_20080513_184207/mozilla-central/configure using autoconf
cd /home/ray/mo/try_20080513_184207/mozilla-central; autoconf-2.13
autoconf-wrapper: unrecognized mode '/usr/bin/autoconf-2.13'
make[1]: *** [/home/ray/mo/try_20080513_184207/mozilla-central/configure] Error 255
make[1]: Leaving directory `/home/ray/mo/try_20080513_184207/mozilla-central'
make: *** [build] Error 2
(Reporter)

Comment 1

10 years ago
There is a note that helps on fix this in the configure section of:

http://developer.mozilla.org/en/docs/Mozilla_Source_Code_(Mercurial)

The page at http://wiki.mozilla.org/Mobile/Build/Fennec did not include this information. I have added it. Where else should this be documented? Or can the need to document this issue be eliminated?
It's named differently on different platforms/operating systems, so no one value will catch everyone. Bug 434075 will have us try several different variations before failing.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 434075
deup v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.