"Print Selection" print blank page

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: vicky.sun, Unassigned)

Tracking

Trunk
x86
SunOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9b5) Gecko/2008050614 Firefox/3.0b5

Steps to Perform:

   1. Load https://bugzilla.mozilla.org/attachment.cgi?id=318692
   2. Select-All
   3. Print, with "print selection" ticked
   4. Examine output

	
Expected Results:

You should receive a total of 3 pages, numbered "1 of 3", "2 of 3", and "3 of 3"

Actual Results:

Nothing is printed
(Reporter)

Comment 1

10 years ago
In this testcase below, just select part of text and  print selection, a blank page will be printed.
https://bugzilla.mozilla.org/attachment.cgi?id=316894

Comment 2

10 years ago
I can reproduce both issues in Firefox 3.0b5 on Linux.
It works fine in Firefox 3.0rc1.

Comment 3

9 years ago
(In reply to comment #1)
> In this testcase below, just select part of text and  print selection, a blank
> page will be printed.
> https://bugzilla.mozilla.org/attachment.cgi?id=316894

I can reproduce the bug exactly as describe, prints full page no problem

Tested using Vista Ultimate & a Cannon Pixma IX4000 printer on main computer &  XP Pro and Epson D92 printer on laptop also produces the same problem
(In reply to comment #3)
> (In reply to comment #1)
> > In this testcase below, just select part of text and  print selection, a blank
> > page will be printed.
> > https://bugzilla.mozilla.org/attachment.cgi?id=316894
> 
> I can reproduce the bug exactly as describe, prints full page no problem

I'm confused... you say you can reproduce the bug, but you also say "prints full page no problem" -- I presume the "full page" is a blank (buggy) page?  Or is it fine?

> Tested using Vista Ultimate & a Cannon Pixma IX4000 printer on main computer & 
> XP Pro and Epson D92 printer on laptop also produces the same problem

What version of firefox?  (Please see Help menu | About, and copy&paste the full version string at the bottom there.)

FWIW, I get expected behavior (no bug) on Linux, using both testcases mentioned above (in comment 0 and comment 1), with this recent nightly:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20081221 Minefield/3.2a1pre

If anyone can still reproduce this bug on SunOS using a recent Firefox build, please say so. (and say which testcase you're using)

Comment 5

9 years ago
Full Page prints OK

selected section/text dose not print = blank page even https://bugzilla.mozilla.org/attachment.cgi?id=316894

Version = 3.0.5
Works for me, using the steps to reproduce in comment 0 and comment 5 with:
Firefox 3.0.5 on Windows XP and Linux.
Firefox 3.2a1pre 20081226 on Linux.

Comment 7

9 years ago
Thanks for a quick repair in the last 24 hours
Paul, are you saying it is working for you now?

Comment 9

9 years ago
Yes it's working now, on my machine with Vista Ultimate not tried the laptop yet with XP Pro.

If there's not been a repair or patch in the last 24 hours then I don't know how or why it's just strted to work, printing selected text, there was never a problem for me with printing a full page.

I've made NO chnges to anything so its a mistary or sants magic.
Ok, thanks.  I'm pretty sure the original problem was fixed on the
1.9.0 branch between 3.0b5 and 3.0rc1 (see comment 2).
Please file a new bug if you still have problems in a trunk build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.