Opening Files is a mess.

RESOLVED DUPLICATE of bug 185618

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 185618
10 years ago
4 years ago

People

(Reporter: John J. Barton, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
FF3pre has problems with opening files. 
1) Try this link:
http://fbug.googlecode.com/issues/attachment?aid=8111369514206310729&name=Picture+1.png 
 FF3 pops up a box "What should Minefield do with this file?"
I want it to open in FF3, dummy. 
  First bug: files that FF3 can render should, by default, render. Even if you disagree, surely that should be a simple option.  This is png file!

So I select "Open with", 
  Second bug: no Firefox to choose. Dumb. This our party!

Ok, browse for it. click, click, Got it. Back to the dialog, ok this time remember to click that box...aaaarrrrrrrrrrggg 

  Third bug: the 'Do this automatically for files like this from now on" box is disabled!

Comment 1

10 years ago
The server says:
  Content-Type: application/octet-stream
  content-disposition: attachment; filename="Picture 1.png"

Dupe of bug 285976?
Whiteboard: DUPEME
(Reporter)

Comment 2

10 years ago
Boris pointed to Bug 185618 as related
(Reporter)

Comment 3

10 years ago
Boris' also has the best solution, 'view in browser'
https://bugzilla.mozilla.org/show_bug.cgi?id=185618#c2
(Reporter)

Comment 4

10 years ago
(In reply to comment #1)
> Dupe of bug 285976?

No, 285976 is part of the problem. The user should have the option of viewing the content in the browser and of doing that with out several minutes of UI work. 
I don't see how this bug differs from bug 185618.
(Reporter)

Comment 6

10 years ago
(In reply to comment #5)
> I don't see how this bug differs from bug 185618.
> 
I think I do.  This bug report is about one specific case with an extremely bad user experience, not about a general case of Content-Disposition: attachment as discussed in 185618. 

In this case:
  1) The user is told in the user interface that the content is "PNG Image".
  2) Firefox takes actions appropriate for application/octet-stream
  3) The user will be faced with a bad experience over and over again.

This mismatch causes the user multiple problems:
  1) PNG-appropriate applications, esp. Firefox, are not offered in the application drop-down,
  2) After the user spends a long time and effort to locate Firefox as their application of choice for downloaded images, Firefox refuses to obey this preference in future,
  3) Because the user interface has identified the content as PNG Image, then acted unlike users expect based on use of Firefox in the past, they reach the reasonable conclusion that this new Firefox is broken.
  4) The only recourse for the user is to either not view the image, view it with an application not designed for internet security, or save it on the disk for later work, very tedious after the first one.

I do believe that if bug 185618 was resolved using a 'view in browser' option, that this bug would also be fixed.

Depends on: 185618
(Reporter)

Comment 7

10 years ago
I think this is the consensus.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 185618
No longer depends on: 185618

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.