Bookmarks layout is NOT productive. Tags are buried and not immediately visible.

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Garry Nichols, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5

While adding bookmarks I had to click a drop down arrow to select a tag for each bookmark. EVERY SINGLE TIME. I even looked for a hidden option to change this. I found NONE.

No matter how I tried to save bookmarks (with tags, without tags, unsorted or in a folder) I could not access my tags without going 4 folders deep.

***This does not seem to be a bug, But a very serious design flaw.***

At first I thought I could work around this, I tried to 'Organize Bookmarks'
I was not able to move the tags or folders to the main list.

This seriously hinders the productivity of this internet browser!
I am sure I am not the only one. Now that I am heard... Please fix this or at least let us customize how Firefox operates with my bookmarks.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox
2.select bookmarks from the menu
3.created tags are not displayed! They are buried under 4 menus.


Expected Results:  
When I add a bookmark aka Ctrl-D I expect less than 2 clicks.
For example...
I wanna bookmark this page.
[Ctrl-D]
[type in name of tag]
[enter]
Done.

Or how about...
[Ctrl-D]
[click an existing tag]
[enter]
Done.

Ok, Now I want to review a page I have bookmarked previously...
[Click bookmarks] or [Ctrl-B]
[select my folder or tag]
[click the link] and page begins to load
Done.

Now if you can bring that back I will reload Firefox 3 and try again.
If this current clutsy bookmark interface makes it into a release of Firefox 3 I will be very **** off.

I also do not like not being able to delete folders such as 'Smart Bookmarks'
If the user doesn't want let them delete it. When software is made to force users ie not let them customize it to fit them it usually forks.

What was wrong with the old way of handling tags in Firefox 2 ???

'Bookmark Tags'
https://addons.mozilla.org/en-US/firefox/addon/998

I have been using Firefox since before it was Firefox. And I have been very patient with the way it has been developed. Until now. None of the features or problems was as upsetting as this one. Please HELP.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk
if you do CTRL+D you can directly write tags into the tags field and click done, in future that field should support auto-complete of tags

and you can delete Smart Bookmarks folder without any problem...
and you can access recent tags from the bookmarks menu. also the location bar search through tags.
If I understood well, you would have an option that shows only tag sort in bookmarks menu instead of the normal tree. Or not?
(Reporter)

Comment 4

10 years ago
Lucas Malor, Yes. You understand exactly. If this is not going to be the default action, then there should be an option to enable that.

The other part is you have hit a drop down list every time to save to an existing tag.
I agree with you. Anyway, it's an enhancement bug, not a major one ;-) Can you change its Severity?
(Reporter)

Updated

10 years ago
Severity: major → normal
(Reporter)

Comment 6

10 years ago
There is an improvement with the latest updates in Ubuntu Hardy 8.04 as of 07/10/2008

I'm not a 100% satisfied, but this is at least usable.  Thanks for all your hard work everyone!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.