page switches direction with single right click

RESOLVED DUPLICATE of bug 403540

Status

()

Firefox
Menus
--
minor
RESOLVED DUPLICATE of bug 403540
10 years ago
9 years ago

People

(Reporter: vin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008050509 Firefox/3.0b5

This is a small ergonomics bug. In every page when right clicking in the lower right quarter of the browser, the "right-click menu" (i dont know the proper name) appears in such a position that the tip of the cursor is over the "SWITCH PAGE DIRECTION" option. As a result a single right click in that area switches the page direction instead of making the menu appear (the menu appears for an instant an then because of the position of the cursor, switch page direction is selected)
  

Reproducible: Always

Steps to Reproduce:
1.right click ONLY ONCE in the lower right quarter of any page
2.watch as the page switches direction instead of the menu appearing
3.
Actual Results:  
the page swithes direction although i didnt want to

Expected Results:  
the right click menu should appear. TO be more precise the menu appears but due to the wrong position it has with the cursor, the "switch page direction" is always selected
(Reporter)

Updated

10 years ago
Summary: page switches direction with right click → page switches direction with single right click

Comment 1

10 years ago
This happens for me also.  Not necessarily 100% of the right clicks, but a good portion result in the page switching direction.

While this might be a bug with some sort of click handler, I would like to be able to remove the "switch page direction" from my right click menu, because I do not use any sites (or know any languages) that are right to left.

Also, there is some odd behavior with right clicking on URLs (in gmail, in my case).  Instead of pulling up the right click menu, it acts as if I chose the "link properties" choice on the menu when I didn't.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 403540
You need to log in before you can comment on or make changes to this bug.