Closed Bug 433936 Opened 12 years ago Closed 12 years ago

Cannot login to Litmus using QA Companion 0.1.13

Categories

(Other Applications Graveyard :: QA Companion, defect)

x86
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: chris.blore, Assigned: cmtalbert)

Details

Attachments

(1 file)

Using the latest version of QA Companion (0.1.13), I am unable to login to Litmus. 

Steps to reproduce:

1. Enter Litmus account details. The Account Creation window opens regardless of whether or not you already have a Litmus account.
2. QA Companion does not login to Litmus and you receive the following error message: ERROR: [Exception... "'Can't add a login with both a httpRealm and formSubmitURL.' when calling method: [nsILoginManager::addLogin]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: chrome://qa/content/prefs.js :: anonymous :: line 182"  data: no]

I am using FF3 RC1 Build 1: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0
Looks like something got changed in login manager to break this. I'll look into it. 
Assignee: nobody → zach
Severity: normal → critical
This patch fixes the error by complying with the nsILoginManager's new rules for submissions.  It also improves our login handling for stored passwords.

If you start QAC, it will do the following:
* Check for your stored password
* If found, will validate your login
* If not found or if validation fails, it asks you to log into litmus
* If you login successfully, it stores your information
* If you do not login successfully, it asks you to log in again.

The "first time" login experience is unchanged and unaffected by this.
Assignee: zach → ctalbert
Status: NEW → ASSIGNED
Attachment #321176 - Flags: review?(jay)
(In reply to comment #1)
> Looks like something got changed in login manager to break this. I'll look into
> it. 
> 
Zach,

Sorry, I didn't realize you were already looking into this.  I went ahead and took it since we have a big RC1 test day tomorrow, and folks will probably want a QAC that works with ffx 3.0 RC1.
That's fine Clint. I had only spent a few minutes poking at it anyway. Thanks for grabbing it so quickly. Patch looks great to me. Perhaps we should direct people to irc for help if they have forgotten their passwords, since that's what the litmus login page says to do?
Comment on attachment 321176 [details] [diff] [review]
Fixes the error and does better management of currently logged in sessions

r=jay, but please bump the maxversion to 3.0.* before checkin, so I won't have to do it manually through the addons site next time. :-)
Attachment #321176 - Flags: review?(jay) → review+
In reply to comment 4:
Good idea, Zach, I'm going to change the text of the "second try" login message to: Incorrect login information.  Please enter the email address and password for your Litmus Account, if you have forgotten it, ask on IRC in #qa to have it reset.

In reply to comment 5:
Done.

Otherwise, the patch is the same as what is above.

Checking in testing/extensions/community/install.rdf;
/cvsroot/mozilla/testing/extensions/community/install.rdf,v  <--  install.rdf
new revision: 1.23; previous revision: 1.22
done
Checking in testing/extensions/community/chrome/content/prefs.js;
/cvsroot/mozilla/testing/extensions/community/chrome/content/prefs.js,v  <--  prefs.js
new revision: 1.7; previous revision: 1.6
done
Checking in testing/extensions/community/chrome/content/qa.js;
/cvsroot/mozilla/testing/extensions/community/chrome/content/qa.js,v  <--  qa.js
new revision: 1.8; previous revision: 1.7
done
Checking in testing/extensions/community/chrome/locale/en-US/qa.properties;
/cvsroot/mozilla/testing/extensions/community/chrome/locale/en-US/qa.properties,v  <--  qa.properties
new revision: 1.6; previous revision: 1.5
done

--> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.