Main window blanked on opening popup

VERIFIED WORKSFORME

Status

()

Core
Document Navigation
P3
major
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Brian Ryner (not reading), Assigned: Adam Lock)

Tracking

({embed})

Trunk
embed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
To see this, go to http://cnn.com, and click the "View Results" link under the
poll.  A popup window with the results appears, but the main window blanks. 
Also, the main window's URL bar has the javascript: URL in it.

Guessing Docshell for the component but not sure.

Reproduced on today's Linux and Windows builds.

Comment 1

18 years ago
The actual javascript executed is:

// this will open a new window, submit the poll form, and send the results to 
the popup window
function pollSubPop (earl, name, widgets, specialsURL) 
{
	host = location.hostname;
	if (host.indexOf('customnews') != -1) 
	{
		var url = 'http://customnews.cnn.com' + earl;
	}
	else
	{
		var url = earl;
	}
	popupWin = window.open(url, name, widgets);
	popupWin.opener.top.name = "opener";
	popupWin.focus();
}

Comment 2

18 years ago
Further analysis suggests the problem is the javascript: href on the link. 
Docshell probably doesn't realise that it shouldn't try to browse to it and ends 
up displaying a blank page. It's sort of related to bug 36081.

Updated

18 years ago
Keywords: embed

Updated

18 years ago
Keywords: nsbeta3

Comment 3

18 years ago
I can't repro this using today's build.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

18 years ago
verified works in current build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.