show_bug.cgi javascript error on changing status

RESOLVED FIXED in Bugzilla 3.2

Status

()

Bugzilla
User Interface
--
major
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Ron Egyed, Assigned: Guy Pyrzak)

Tracking

3.1.4
Bugzilla 3.2
x86
Windows XP
Bug Flags:
approval +
blocking3.2 +

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.42 KB, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: 3.1.4

On Internet Explorer 7.0.5730.11 the show_bug.cgi page encounters a javascript error.
As a result of the javascript error, the resolution dropdown box is never displayed.

Reproducible: Always

Steps to Reproduce:
1. Create a new bug from internet explorer 7
2. Revise the bug.
3. Change status to resolved.
Actual Results:  
javascript error at line 264 of field.js when form is first displayed.
Resolution dropdown does not display when status is changed to resolved

Expected Results:  
No javascript error should occur when page is first displayed.
Resolution dropdown should display when when status is changed to resolved.

This error occurs with the classic and dusk themes.
The cause of the error is IE does not support indexOf for an array.
(Reporter)

Comment 1

10 years ago
Created attachment 321187 [details] [diff] [review]
javascript field.js fix for ie7

Here is a proposed fix for the unsupported indexOf javascript function on an array in ie7.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.1.4
(Assignee)

Comment 2

10 years ago
good find on the bug, not the way we should fix it though. We should remove any instances of indexof and replace it with bz_isValueInArray(aArray, aValue)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

10 years ago
Flags: blocking3.2?

Updated

10 years ago
Severity: normal → major
Flags: blocking3.2? → blocking3.2+

Updated

10 years ago
Summary: show_bug.cgi javascript error → show_bug.cgi javascript error on changing status

Updated

10 years ago
Target Milestone: --- → Bugzilla 3.2
(Assignee)

Comment 3

10 years ago
Created attachment 321196 [details] [diff] [review]
patch v1
Attachment #321187 - Attachment is obsolete: true
Attachment #321196 - Flags: review?(mkanat)

Comment 4

10 years ago
Comment on attachment 321196 [details] [diff] [review]
patch v1

This is fine as long as you confirm that util.js is already loaded in all the pages where field.js is loaded.
Attachment #321196 - Flags: review?(mkanat) → review+

Updated

10 years ago
Flags: approval+

Updated

10 years ago
Assignee: ui → guy.pyrzak
Status: ASSIGNED → NEW
(Assignee)

Comment 5

10 years ago
Checking in js/field.js;
/cvsroot/mozilla/webtools/bugzilla/js/field.js,v  <--  field.js
new revision: 1.8; previous revision: 1.7
done
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Duplicate of this bug: 436306
You need to log in before you can comment on or make changes to this bug.