Copying message to a JA folder on POP account (on non Japanese system) causes a crash

VERIFIED WORKSFORME

Status

MailNews Core
Internationalization
P3
major
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: marina, Assigned: nhottanscp)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

(Reporter)

Description

18 years ago
**** observed with 2000-06-21-08 build on EN Win NT40 ****
Steps to reproduce:
- create a JA folder under POP tree;
- select a message(any message, it doesn'thave to be JA message) and drag/drop 
it to JA folder;
//note : seamnokey crashes
(it doesn't happen on IMAP)
(Assignee)

Comment 1

18 years ago
Could you attach a talkback info for the crash?

The feature is not supported (JA folder under US windows) but we want to prevent 
the crash.
cc to putterman, m_kato@ga2.so-net.ne.jp.

Comment 2

18 years ago
Adding crash keyword
Keywords: crash
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 3

18 years ago
here is a stack:
   
   nsMsgDatabase::CopyHdrFromExistingHdr 
                                             
[d:\builds\seamonkey\mozilla\mailnews\db\msgdb\src\nsMsgDatabase.cpp, line 2328]
     
   nsMsgLocalMailFolder::EndCopy 
                                             
[d:\builds\seamonkey\mozilla\mailnews\local\src\nsLocalMailFolder.cpp, line 
2272]
     
   nsCopyMessageStreamListener::OnStopRequest
                                             
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsCopyMessageStreamListener.cpp, 
line 166]
     
   nsMsgProtocol::OnStopRequest 
                                             
[d:\builds\seamonkey\mozilla\mailnews\base\util\nsMsgProtocol.cpp, line 229]
     
   nsMailboxProtocol::OnStopRequest 
                                             
[d:\builds\seamonkey\mozilla\mailnews\local\src\nsMailboxProtocol.cpp, line 200]
     
   nsFileChannel::OnStopRequest 
                                             
[d:\builds\seamonkey\mozilla\netwerk\protocol\file\src\nsFileChannel.cpp, line 
630]
     
   nsOnStopRequestEvent::HandleEvent 
                                             
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
302]
     
   nsStreamListenerEvent::HandlePLEvent 
                                             
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
106]
     
   PL_HandleEvent 
                                             
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 576]
     
   PL_ProcessPendingEvents 
                                             
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 539]
     
   _md_EventReceiverProc 
                                             
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 1034]
     
   USER32.dll + 0x124c (0x77e7124c) 
                                              
(Reporter)

Comment 4

18 years ago
I want to add some important comments: it does crash on JA NT as well, so i 
think it should be nominated for beta2
(Assignee)

Comment 5

18 years ago
Nominating for nsbeta2.
Marina, could you attach a test case (zipped mbox files)?
Keywords: nsbeta2
(Assignee)

Comment 6

18 years ago
Using today's win32 build ID 2000071008, I cannot reproduce the crasher.
I tested on Japanese NT4, copied messages between Japanese named folders.
I was able to copy files and saw no crash.

Comment 7

18 years ago
Putting on [NEED INFO] radar. PDT needs to know impact to user and risk of fix 
to make a call on this bug. 
Whiteboard: [NEED INFO]
(Assignee)

Comment 8

18 years ago
If this is reproducible on Japanse Windows then this is not good as the user 
cannot copy messages (also crashes). But I have not been able to reproduce this 
on my Japanese NT.
About risk of fix, I want to ask opinion to Scott Putterman or David Bienvenu, 
since it's crashing around msgdb.

Comment 9

18 years ago
I am not able to reproduce this bug on Japanese Windows NT-4.
I have a feeling that this problem is related to the other
problem where extra sub-folders are created under a newly
created JPN named folder uner non-JPN OS. 

Comment 10

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2. 
Whiteboard: [NEED INFO] → [nsbeta2-]
(Assignee)

Updated

17 years ago
Summary: Copying message to a JA folder on POP account causes a crash → Copying message to a JA folder on POP account (on non Japanese system) causes a crash

Comment 11

17 years ago
Adding myself to the list.

Comment 12

17 years ago
I tested in Win2000-Japanese, and it didn't crash.
Here is what I did:
1) Created a JA folder [system locale is JA] and close Mail
2) Go to Control Panel and change the system locale to English then ReBoot
3) Open Mail and copy message to the JA folder [Note: JA folder is shown ???]
4) Mail didn't get copied; but no crash.

I tested on NT4-Eng with Japanese GlobalIME and still no crash.
1) Create a JA folder
2) copy message to the JA folder [Note: JA folder shows in Japanese :)]
3) Mail didn't get copied; but no crash.



Comment 13

17 years ago
Is this bug now workforme ? If so, please take it out of the radar.
(Assignee)

Comment 14

17 years ago
worksforme (at least no crash)
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 15

17 years ago
marina, please check to see if this still occurs.
QA Contact: momoi → marina
(Reporter)

Comment 16

17 years ago
it didn't crash with 2000-11-04 build but nothing is copied and the folder is
empty. Although it is not easy to access the JA folder, for a while you get an
impression the it hangs. I'll enter a bug about no copy's done for a JA folder
on US system. I'll verify this one as fixed ( i did crash once when changing
folders from JA to Inbox?)
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.