Closed Bug 434009 Opened 12 years ago Closed 9 years ago

Replace Task Progress bar colors

Categories

(Calendar :: Calendar Views, defect)

Lightning 1.2
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: chris.j.bugzilla, Assigned: Paenglab)

References

Details

(Keywords: polish, Whiteboard: [good first bug])

Attachments

(5 files)

The new Task Progress bar (-> bug 273600)is colored black this should change to something friendlier.

For the border I suggest to use:

border: 1px solid ThreeDShadow;

for the progress itself:
#17DA27

the total height of the progress bar should be:
12px
Can possibly be accomplished using the

treechildren::-moz-tree-progressmeter(atom1,atom2,...) {

}

pseudoclass. Not quite sure its possible to change the height, but its worth a try. Also try setting some attributes in ::-moz-tree-cell.
Whiteboard: [good first bug]
Attached image Recolored Progress bars
In my opinion no further action is required.

This screenshots shows the task progress bar in Thunderbird on Windows XP using different Thunderbird themes. Three of the themes (CrossOver, CuteBird (Blue) and Leopard Mail-Default-Aqua) claims to bring an Mac-/Aqua-like look to Windows. 

Guess what? This are the themes that change the progress bar to black color on purpose. The same black that is complained about in Bug 273600 Comment #11.

I can't tell if the black is really Mac-like. But setting the progress bar to a non-native color means that it won't look integrated into Thunderbird because it looks different then other progress bars (e.g. when fetching mail).
Other progress bars look way different anyway. See attached screenshot. Thunderbird doesn't use any trees that contain progressmeters.
I've heard that on windows/linux its possible to use an image as background, which would allow us to use semi-native styles, but that will end up in being a mess similar to the checkbox in the task tree.
To get this discussion running again, an idea that I had for the progress bar:
It should be possible to change the color on percentage of completion.

This could be done in three ways:
1.) Using the HSV-Color-Model and changing the saturation.

2.) Using an e.g. green overlay box and changing the opacity towards 100%.
3.) Using an e.g. red overlay and reduce the opacity upon completion to 0%

The latter 2 using RGBA- or HSLA-colors with A being the transparency channel.

The Gecko Engine supports both models and these progress-bars would also be skinnable.

The first solution could also be accomplished with Hex-Style colors, but the calculations would be a lot mor difficult.
The task progress bar doesn't exists anymore in Sunbird/Lightning 1.0pre builds.
I was thinking about the Status bars in Task mode now.

I think, either we should take the bug for this as well (as these bars are gray which is not much different than black) or close it.
What happened to the progress bars, anyway? I can't seem to find any in either task mode nor in the today pane.

While the idea with using an overlay image to color different tasks in different colors sounds like a very nice idea (I'd use it! :-), is this something we want to force upon all users? I'll leave this to Bryan.

Bryan, could you look into this?
Assignee: nobody → clarkbw
Keywords: polish, uiwanted
> What happened to the progress bars, anyway?

Disappeared when switching to trunk. Tracked with Bug 459352.
For a11y to work in Linux we probably need to use the CSS system colors [1].  I'd guess Highlight is the correct one for some color.  System colors aren't exactly pretty but there isn't too much choice as it's controlled by the theme.

In Windows you can detect the default theme and use nicer colors for that, falling back to system colors if not the default theme.

(In reply to comment #9)
> While the idea with using an overlay image to color different tasks in
> different colors sounds like a very nice idea (I'd use it! :-), is this
> something we want to force upon all users? I'll leave this to Bryan.

I don't think I understand what you mean here.

[1] http://www.iangraham.org/books/xhtml1/appd/update-23feb2000.html
Assignee: clarkbw → nobody
Duplicate of this bug: 611681
Giving the highlight color as progress bar color after Clark's proposal. I tried to give some gradient to look a little smarter but the tree progress bar supports either a color or a image but not both. I let the padding because this gives a border around the progress bar and separates the bar from the selected treechildren which mostly have the same color.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #577072 - Flags: review?(philipp)
Comment on attachment 577072 [details] [diff] [review]
Highlight as progress color

Looks good, r=philipp. I think we can take Clark's comment as a ui-review, unless someone objects?

a=philipp for aurora too
Attachment #577072 - Flags: ui-review+
Attachment #577072 - Flags: review?(philipp)
Attachment #577072 - Flags: review+
Pushed to comm-central: http://hg.mozilla.org/comm-central/rev/68838a580fb7
and to comm-aurora: http://hg.mozilla.org/releases/comm-aurora/rev/5e5e2914d866
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Version: unspecified → Lightning 1.2
Target Milestone: --- → 1.2
You need to log in before you can comment on or make changes to this bug.